summaryrefslogtreecommitdiff
path: root/dev-python/trustme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
commitf9a53aec073578673710687755db617717dd87d3 (patch)
tree9e9642aae0c5bc25cac799d6a2437229bbb76a76 /dev-python/trustme
parent7e110ec617b903791c3d309845e11a8b27f441cc (diff)
gentoo auto-resync : 11:07:2023 - 10:29:18
Diffstat (limited to 'dev-python/trustme')
-rw-r--r--dev-python/trustme/Manifest2
-rw-r--r--dev-python/trustme/trustme-1.1.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/trustme/Manifest b/dev-python/trustme/Manifest
index 31da9b49f776..0ea032d2af2b 100644
--- a/dev-python/trustme/Manifest
+++ b/dev-python/trustme/Manifest
@@ -1,3 +1,5 @@
DIST trustme-1.0.0.tar.gz 29567 BLAKE2B d57049d5d72b0aca85911a39f1eed2388829ab7e6833a2f8cb7fccf6d743e99fdc7e2917382f1397787c70763bf2ea49210337021054fc549e7e95377f88dc52 SHA512 4315290b5c7341ede5037ece01608ab0e8e07427c8053e058fb5db23f59b0be63b44fda83d83d0755f44c2a0d595b193ca77050c5f908038be071c18d759756a
+DIST trustme-1.1.0.tar.gz 29611 BLAKE2B 71210845c3bb919b731ab14db72376aa701c547c4b062e4dab9ccbb6b97c3416cb48b92a998aa26c85720b38514998e62005dd310513fc80a54502432ee4000b SHA512 f0ad39ffd9f4074107c90258738412ff8ca8ed1b4138e38edc6edad9a5cb8787a53a47fa78b12eba189774902ee3728961feed54b3b5e944e4737749912627b2
EBUILD trustme-1.0.0.ebuild 777 BLAKE2B b33e449bd3d346f60b02ec73d4896f48a2c94a45b0ab2aa9e0163c3c4b78559c7029953cfd57314dcdcd6556e7c899978b03df9b85e031eccea497e789166781 SHA512 ac038b29c1b2c65cd5f088ea132f8403aa54e8c175622c78058814169e0a3610cd652995b31409f0244ff2aedd130be396a3890f44aadc840aef0f34d7662199
+EBUILD trustme-1.1.0.ebuild 784 BLAKE2B 2e9fb45fe4714dfc704a1308324565c9ae8091d58991f51c3893b45f658c665479c4b449f3b23c219b5c93edc68d8926d22962bf2d6056af7e4b6dd259c8fea3 SHA512 452b9fc03ea62b02d60aacd63e4ed6865d5ef194f34905fcd8c2026d082c4bfb45cb528923d0531fb5d2a178ddd09577e2b5cadebe9bdfa86a6b8a3505c7605a
MISC metadata.xml 503 BLAKE2B f9759fc8612b385d57ad6734f363b0d03a7a354c4486ebe98ee855c35d0ca11d54be27cb78b21b56178350bc5520908d2efa8345ecb060fc87bc784303325f2d SHA512 477a6d3a46f72e9a813c04102556742545798868dc526376f90dcc43cfd7675479271f5b0cc4a718e35c74e663a3f99db939202e771f2ff731adf871b161df00
diff --git a/dev-python/trustme/trustme-1.1.0.ebuild b/dev-python/trustme/trustme-1.1.0.ebuild
new file mode 100644
index 000000000000..2f523bf96867
--- /dev/null
+++ b/dev-python/trustme/trustme-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="
+ https://github.com/python-trio/trustme/
+ https://pypi.org/project/trustme/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/cryptography-3.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/service-identity[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest