summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
commit56a597689e7509193b0924a635d2022f21b1a3e4 (patch)
tree476358a5cea634edc1fb0504f6ec03b282cfb83e /dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild
parent57e2174dcd454b41778b7b437f88d0a9f1a6e428 (diff)
gentoo auto-resync : 04:03:2024 - 11:43:04
Diffstat (limited to 'dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild')
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild
new file mode 100644
index 000000000000..3172a692bdd9
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}