summaryrefslogtreecommitdiff
path: root/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 06:01:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 06:01:43 +0100
commit0cdd46ad5d0cd7ede78815175764fdf76649d46e (patch)
tree8ece938369c65a410a308f3f05ebb9d2a7fdc008 /dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild
parentd33b3cf6cff9fdbfc8362bf854c3c34b2c28d518 (diff)
gentoo auto-resync : 21:04:2023 - 06:01:43
Diffstat (limited to 'dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild')
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild
new file mode 100644
index 000000000000..e404744e2dba
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}