summaryrefslogtreecommitdiff
path: root/dev-python/trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-06 08:06:16 +0100
commit4187bba080530c5ca1c7dae9c233e88f3fc8f535 (patch)
treeb6f535e053876097ced1b6bda14a4da890c730d4 /dev-python/trio
parent2a8d2f71d1d9963368e0ef3d641d75979a689d12 (diff)
gentoo auto-resync : 06:07:2024 - 08:06:15
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/Manifest2
-rw-r--r--dev-python/trio/trio-0.26.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/trio/Manifest b/dev-python/trio/Manifest
index f75fc683de37..68b127308c53 100644
--- a/dev-python/trio/Manifest
+++ b/dev-python/trio/Manifest
@@ -1,5 +1,7 @@
DIST trio-0.25.1.gh.tar.gz 600963 BLAKE2B f72df0069ff48f198f7c31221c721ffb127c4cac6c4e004547d62aa5f184673fde09e2baad5c383b206deffec4ef1b04dafad883dad0b2ced2625d72ac842887 SHA512 0a924a1c52ed5153e51cc3343c92b7f6218cf8c56ba2e66b6fe40d27d2acfa7475c3014b8fc5fd22e46df1782530a75f899dbb35d1c875331400957891bd70aa
+DIST trio-0.26.0.gh.tar.gz 609710 BLAKE2B ec263e5db731760472111b8eb6a7d6ebdc476f8dc0976787692289caa5d5361a1a3db03d4713f14ee3198ad45dcec19c6c672af4af3860c3cd7ad5ff3e13bc8a SHA512 9a51f4e71795083ffd4a606e989583b1a93e45dc32f93d2d03bccaf32ca62a82daaf964676636363711b7ea1675dddd3eac1acae1be73b0fc570baef3c37c748
DIST trio-0f5fc6cbafa3e7c84f258d1865996d97ae67a318.gh.tar.gz 609698 BLAKE2B db34b8a3157b78340f75fc07d8c2dc333610d962c3849fce3906e643159904ef28cb94fed062c4607a114f9de3bfa822706c2ea6a5eef5833d17e25690c83603 SHA512 692092451376be2424faf395bbdc4f61bec91f6807a0f04d1c701fc2767a4c844830f93b01cf5a813febf9d267a52d968f4f5f8b983eb7cc5ffcb91cc716739a
EBUILD trio-0.25.1.ebuild 1742 BLAKE2B 4f821136c5e31f4793e12e9355888211c761e3c8e7cb271d07850e421a6231dfb29d32f15064e3c110c70ab05c1ad14f08538cb86604b1007ef9f74870f2ad3d SHA512 fe4807a9245936cdc8b40de43c0da48467310c9882b516768190ae9c395ae2e59eea27488d17e47c9ebc9ee3a8b64dcab8b2a466885c4fa5be22d049d767b458
EBUILD trio-0.25.1_p20240613.ebuild 1868 BLAKE2B 41253e42660bafea11193d799ea542aec964b4dadec772c72a4fe09107607767fbea00e7afc6fd2726d463ac7ba71e577123c9492e76565a8c575d21667dbcca SHA512 1aaf316ed20ed9695bf9f903627ee8050fc500b7d6fb461fba67f00b33a15076b84bb302e502e9e34a1ca841fa582e19d773a0f3d690754b6bcbe887c8f45c13
+EBUILD trio-0.26.0.ebuild 1757 BLAKE2B c9354d0d68f61919d0c0303a4f589cddfb89749f5f878b443efd588de9973fc603b1e9068e2924f1d23b0bdb13c98039a4782def2066094fd5b8dc35adcce9ae SHA512 ad74bda9a451180e4d6aacd87761b7f16e39e49388cc41902ed00bd454a324eed697f08cf5300c66fdfcf14a391a531000a7631a4d5834d1ae74e31ef81f3660
MISC metadata.xml 2060 BLAKE2B bb6ddfddfb3c19038e5982227a8c5f9999b93868c343a9a5bf7af5963006b5b719ef960f65b91747dfddf19544134db9e1a2d65e94192c079c64c303cdc8997a SHA512 4b86e7cccddc200d5616550e309ad46587f900ed13c38196e874e5110974b856d65e18745b8b7b42858cb672940ba280b0c2ea54d33f9b5bf32a375fa1232088
diff --git a/dev-python/trio/trio-0.26.0.ebuild b/dev-python/trio/trio-0.26.0.ebuild
new file mode 100644
index 000000000000..01b349cf4ec8
--- /dev/null
+++ b/dev-python/trio/trio-0.26.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for async concurrency and I/O"
+HOMEPAGE="
+ https://github.com/python-trio/trio/
+ https://pypi.org/project/trio/
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.1[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.3.0[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Bug https://bugs.gentoo.org/916756
+# distutils_enable_sphinx docs/source \
+# dev-python/immutables \
+# dev-python/sphinxcontrib-trio \
+# dev-python/sphinx-rtd-theme \
+# dev-python/towncrier
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Times out on slower arches (ia64 in this case)
+ # https://github.com/python-trio/trio/issues/1753
+ tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
+ # requires ruff
+ _tests/tools/test_gen_exports.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf trio || die
+ epytest -p trio._tests.pytest_plugin \
+ -m "not redistributors_should_skip" \
+ --pyargs trio \
+ --skip-optional-imports
+}