summaryrefslogtreecommitdiff
path: root/dev-python/trio/trio-0.22.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
commit1e9c38efad2f42ea208e40924d1e5936810ac7c0 (patch)
treedbcaa52c820c84eaba974e8a5bf4ba2b05a4bed2 /dev-python/trio/trio-0.22.1.ebuild
parent1f6d51a43dbfcb87ef81da70c688d354560e846a (diff)
gentoo auto-resync : 02:08:2023 - 22:51:19
Diffstat (limited to 'dev-python/trio/trio-0.22.1.ebuild')
-rw-r--r--dev-python/trio/trio-0.22.1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/trio/trio-0.22.1.ebuild b/dev-python/trio/trio-0.22.1.ebuild
deleted file mode 100644
index c7b8024a8f70..000000000000
--- a/dev-python/trio/trio-0.22.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for async concurrency and I/O"
-HOMEPAGE="
- https://github.com/python-trio/trio/
- https://pypi.org/project/trio/
-"
-SRC_URI="
- https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="|| ( Apache-2.0 MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/exceptiongroup-1.0.0_rc9[${PYTHON_USEDEP}]
- ' 3.{9..10})
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/outcome[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/astor-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/immutables-0.6[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/immutables \
- dev-python/sphinxcontrib-trio \
- dev-python/sphinx-rtd-theme \
- dev-python/towncrier
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these tests require internet access
- trio/tests/test_ssl.py
- trio/tests/test_highlevel_ssl_helpers.py
- )
-
- local EPYTEST_DESELECT=(
- # Times out on slower arches (ia64 in this case)
- # https://github.com/python-trio/trio/issues/1753
- trio/tests/test_unix_pipes.py::test_close_at_bad_time_for_send_all
-
- # incompatible ipython version?
- trio/_core/tests/test_multierror.py::test_ipython_exc_handler
- )
- if [[ ${EPYTHON} == python3.12 ]]; then
- EPYTEST_DESELECT+=(
- trio/_core/_tests/test_run.py::test_nursery_cancel_doesnt_create_cyclic_garbage
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p trio._tests.pytest_plugin -m "not redistributors_should_skip"
-}