summaryrefslogtreecommitdiff
path: root/dev-python/trio-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /dev-python/trio-asyncio
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'dev-python/trio-asyncio')
-rw-r--r--dev-python/trio-asyncio/Manifest2
-rw-r--r--dev-python/trio-asyncio/trio-asyncio-0.12.0-r1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/trio-asyncio/Manifest b/dev-python/trio-asyncio/Manifest
index 69a0f68b5f49..81252ca82201 100644
--- a/dev-python/trio-asyncio/Manifest
+++ b/dev-python/trio-asyncio/Manifest
@@ -1,4 +1,6 @@
AUX no-pytest-runner.patch 442 BLAKE2B ff5900203f9c5d113a822f6233e2391d7eb1dd815709dd8a9e2ed30c18273125cdcd9ac2940870f81e9de3bcf9db130f2dd3a9492820b15ddec282759fb5e52b SHA512 7776f8a2445f35ff83324eba5aed4672f2e20e57a8a89c13360e32aa6c12d13df6fa1801b4a671797d5f7de8e1fee174f4e94d36617a382e536261bf05a64bcc
+DIST trio-asyncio-0.12.0.gh.tar.gz 72508 BLAKE2B f2dad48e20dadb81f603f8e7edf5d108f5c1dec332e65599e06495a9e3b919d20a15e3cb0d4f06c46a0e844cd79a88c172043b5cae2bc632661679a9ac854c04 SHA512 da630bf95d0736efd419a7b84d3fcb55f4440ef5f3ac584f36b2eca9188145d4581b20d4842b1322b07f176822f7c76e32ae57ac71899ea2445ce1783bcd382c
DIST trio-asyncio-0.12.0.tar.gz 72508 BLAKE2B f2dad48e20dadb81f603f8e7edf5d108f5c1dec332e65599e06495a9e3b919d20a15e3cb0d4f06c46a0e844cd79a88c172043b5cae2bc632661679a9ac854c04 SHA512 da630bf95d0736efd419a7b84d3fcb55f4440ef5f3ac584f36b2eca9188145d4581b20d4842b1322b07f176822f7c76e32ae57ac71899ea2445ce1783bcd382c
+EBUILD trio-asyncio-0.12.0-r1.ebuild 1288 BLAKE2B 9ac131dfd18e03c10180640886d37030798d6634f6b239ac8f9c2091cc548c8d0a7aaa2428dbb90a755057d5120bfadf4615efbefc3a05d03ba9cc3da0e25bfc SHA512 edd5ddbf09154531111a984a8c97c0189ed75b1ba7ecedfa3c7921ec630ba1989fa8f0ef85e060e2e3193e33989bd8575ed89132ce116681c2f35d65950f11c4
EBUILD trio-asyncio-0.12.0.ebuild 865 BLAKE2B 6fb7eaaf4da11e8e8509c343e69d795dfda89f5f998f5630f784386d53aee4c493b355d6aed1d8f07897f1ac13a4491ef52fcaafc5921919f5ace04ef3cd25ca SHA512 8260b188b839422cb954ee290229807fe58672d67b33e645aafaa109acaaf2efe8f9eebedb693f4a48f3b0dfaff399da61ff55430af4cee6d16603251c6c1fc8
MISC metadata.xml 1455 BLAKE2B 3d71fe362fb2826f29e73629317c36a03db5c9d09a1cc1cee4746148fc0d5c8519c39babfa097b6651b815812fa6645ae12ae88267573c037777423fcde746be SHA512 efad9b325ce373a81305600d9a3dbad3ec7049eb71496741d5303348db9f94bc77a5e46a490bf2295f49d4cf74f5dc997961fc4551435f6277ab3dbd3ae9dd7c
diff --git a/dev-python/trio-asyncio/trio-asyncio-0.12.0-r1.ebuild b/dev-python/trio-asyncio/trio-asyncio-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..32be0ae5ec74
--- /dev/null
+++ b/dev-python/trio-asyncio/trio-asyncio-0.12.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="a re-implementation of the asyncio mainloop on top of Trio"
+HOMEPAGE="
+ https://github.com/python-trio/trio-asyncio
+ https://pypi.org/project/trio-asyncio/
+"
+SRC_URI="https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/outcome[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.15.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-trio-0.6[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/no-pytest-runner.patch" )
+
+EPYTEST_DESELECT=(
+ # RuntimeError: You're within a Trio environment.
+ # https://bugs.gentoo.org/834955
+ /Python-3.8/test_asyncio/test_locks.py::ConditionTests::test_ambiguo
+ /Python-3.9/test_asyncio/test_locks.py::ConditionTests::test_ambiguo
+ /Python-3.10/test_asyncio/test_locks.py::ConditionTests::test_ambiguo
+ /Python-3.11/test_asyncio/test_locks.py::ConditionTests::test_ambiguo
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio dev-python/sphinx_rtd_theme