summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 11:44:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 11:44:03 +0000
commitdf26c7469c1f2af2e643d43e2e32a6c9142e4885 (patch)
tree1beee9b11d06bfcc69d1d6c8ab00566f8633aec1 /dev-python/trimesh
parentad391b961414c99124b93cb86695c04bd8d57937 (diff)
gentoo auto-resync : 11:01:2023 - 11:44:03
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-3.18.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 25f9b8ae142e..85462814ef3b 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.16.0.gh.tar.gz 11970053 BLAKE2B 3898dd2fd12fd070bc9a3a10e21bd255b75f7758deb38e0d36314524b4e24b7ada6514865c06677a1db39b1723b918e5ec6dcf491bf0c946c3e22495cf7dcd01 SHA512 7b56a5007614eae8a7cef1a69334ef3b21499572b5bfaa414bd29097a431266e1ec4d7dda540dbf502a57f5b0ce9d3fb3763675821714ac25d924e0d15e22c71
DIST trimesh-3.17.1.gh.tar.gz 12653345 BLAKE2B df286132ca01e1a7e8c226b7c98ffa0682b9bf2e225c4114c88395611d1a65a02be4395940ad04b67ae3b6909664b46e18e9fd018d892c86f8f5a4fcfe532210 SHA512 8cbf0bedd21c0867c5aa307e9bb8b4e4caff2aabee89cfadfa11513293304caa4b6a5ecce21064b7fa157a2453b58d401eb6010d0ea32bbd5a99c3075f38b826
+DIST trimesh-3.18.0.gh.tar.gz 12656666 BLAKE2B e183ab1b5ff904b54a7801aaf9e6a3ac24a277107dae03dd37be7a37c56835ac99b617af1c12ea4119c39c3c064d8d1e783ce6effa51ebc0bc65103e688ad363 SHA512 309e1c5dd17a2d1875254a732d96708b98635cbd17ceea80c5386d6ea4675f943e1760f7a4383e9c24ec5711d30ea0732883a691952da1d1079a81a87fcca6cc
EBUILD trimesh-3.16.0.ebuild 1863 BLAKE2B 7b8f0fc5c878d18b0ac6ff779474555e6ce2eef6f86fdf2da2e8e547351de67485d6d7c0092bc19e0e0be29ea9e0eb9c9180fb387c3075b8ee3f38869d4848d2 SHA512 f015e4269fa2282a8827c764d5d23c5fbbf5f1de5c509e651e29fb91983157114b13fb832c80a3600b6ae2ccf48a0e9b1ac15dd0880d56443c24632980e2b3e7
EBUILD trimesh-3.17.1.ebuild 2218 BLAKE2B 22a1b43f5e3e2164da691ff85ab46d48e40dd018cf20bac6fb125acb43cfcbd1a84fb9666d83cd7d2888f7c09c109953f18889a93f9a7bdba692af251d14fe5a SHA512 43394ec222da28ce755caaf42b692d030bddc7244f9c7e7a54b58bcc84ea19d1ccdb25c768aaa1e2d003a8db8ac82b7a31fd16849ebca82e9713241a5b163400
+EBUILD trimesh-3.18.0.ebuild 2218 BLAKE2B 45f59b6d13653ec77ba1fc78a5b7eb1f77be1373f7f723596be7b89cb7a27b2434ccf86637c61fb14cd22e674a3fb1b0041782895c8c28aa539aaaba4b40a510 SHA512 368de2a03ccfa3d87294b65841943c2734afd701dc2352689b27e2e87fdf0900e87c6373cbbc605f7f7fb314b2366fe8eee1f86c0b21b55e88ce7933f6513207
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-3.18.0.ebuild b/dev-python/trimesh/trimesh-3.18.0.ebuild
new file mode 100644
index 000000000000..5cbb40238b4f
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.18.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ <dev-python/pyglet-2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pyinstrument from tests, as only used for profiling
+ sed -e '/pyinstrument/d' -i tests/{regression,corpus,generic}.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # does profiling with pyinstrument
+ tests/test_scenegraph.py::GraphTests::test_shortest_path
+ )
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}