summaryrefslogtreecommitdiff
path: root/dev-python/trimesh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-08 21:16:36 +0000
commit750f865355947c40a4b93cd7a5db23eebc4e5080 (patch)
treed09084ef3a0baa1b4e6adbdbb4e85abc21f6650f /dev-python/trimesh
parentc51985271f4c8e0bc79728c6cecf15d6b6515914 (diff)
gentoo auto-resync : 08:12:2022 - 21:16:36
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-3.17.1.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 8492af307e98..318f6d2544c9 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,5 +1,7 @@
DIST trimesh-3.15.8.gh.tar.gz 11972365 BLAKE2B 2dd76c5f3c6949b79992dc23a4a80f3fc80c63c08ac7f8c6c11d6b1209b7b23f4843fe0da74528fbec0738bf83d2791260183cca710d2fe046c1bb8ef747c82b SHA512 806a8a10ff86a5198f7dc134f07fa3fd3f84d8e1b10f2d1f8dbc4a5783d2d24474d7c32f0427fd740f2af63d544fc4f3e710f1904cca0412390e6913092b1741
DIST trimesh-3.16.0.gh.tar.gz 11970053 BLAKE2B 3898dd2fd12fd070bc9a3a10e21bd255b75f7758deb38e0d36314524b4e24b7ada6514865c06677a1db39b1723b918e5ec6dcf491bf0c946c3e22495cf7dcd01 SHA512 7b56a5007614eae8a7cef1a69334ef3b21499572b5bfaa414bd29097a431266e1ec4d7dda540dbf502a57f5b0ce9d3fb3763675821714ac25d924e0d15e22c71
+DIST trimesh-3.17.1.gh.tar.gz 12653345 BLAKE2B df286132ca01e1a7e8c226b7c98ffa0682b9bf2e225c4114c88395611d1a65a02be4395940ad04b67ae3b6909664b46e18e9fd018d892c86f8f5a4fcfe532210 SHA512 8cbf0bedd21c0867c5aa307e9bb8b4e4caff2aabee89cfadfa11513293304caa4b6a5ecce21064b7fa157a2453b58d401eb6010d0ea32bbd5a99c3075f38b826
EBUILD trimesh-3.15.8.ebuild 1863 BLAKE2B 7b8f0fc5c878d18b0ac6ff779474555e6ce2eef6f86fdf2da2e8e547351de67485d6d7c0092bc19e0e0be29ea9e0eb9c9180fb387c3075b8ee3f38869d4848d2 SHA512 f015e4269fa2282a8827c764d5d23c5fbbf5f1de5c509e651e29fb91983157114b13fb832c80a3600b6ae2ccf48a0e9b1ac15dd0880d56443c24632980e2b3e7
EBUILD trimesh-3.16.0.ebuild 1864 BLAKE2B 6342098e247117e1d01b4709787765b5a12c9ae1e74fc0b7f028f397bb72ce8478ffa7364add4d5886ac1dd1a9d1e2e167f25d55cf9109dcc0d11148bed89e2e SHA512 7518ddb6538df22b9b56e1e097e597f276d12b8e333051c88fc5c9370b745e72feaf355495268003ee9001a8c57f88aa7822cf80635525ff295f1e3f241ca7e9
+EBUILD trimesh-3.17.1.ebuild 2206 BLAKE2B 8881eb614cf252628412d5a47caa887c7d2302d06508944f73881d4e077014cb56abdc667a78f997255244c4903f7d58b23f496d699861daafa4ba58b8115008 SHA512 b48831125256dae0aa2eaff47f5ee15d653ae8b9c5e0027f58dec75896607bf9dadc09b370617c520c3a4a98898526422c210e25019e5107194c2f56d63e065e
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-3.17.1.ebuild b/dev-python/trimesh/trimesh-3.17.1.ebuild
new file mode 100644
index 000000000000..9ee79542bc0e
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.17.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ <dev-python/pyglet-2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pyinstrument from tests, as only used for profiling
+ sed -e '/pyinstrument/d' -i tests/{regression,corpus,generic}.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # does profiling with pyinstrument
+ tests/test_scenegraph.py::GraphTests::test_shortest_path
+ )
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}