summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/tqdm
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest2
-rw-r--r--dev-python/tqdm/tqdm-4.66.5.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 24620bca170b..3c45af4fa059 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,4 +1,6 @@
AUX tqdm-4.66.4-py313.patch 1406 BLAKE2B a5dd8f73d1aa56f82870ee189814a268a81cc1698f853721069ce99910a499cbf49ab3bcfb39d3ecb7f68cfd5c9e47fd45d4f9e507a5e4fa612df2563309599e SHA512 f1aadbd8ef1f5a50004a02cc6d70eda9386cee793bac2f1933a0e8f89206e8901005f83c98502987348ef0a838a706a598e3c0bd9c4962df0f215f8a2c4fdb29
DIST tqdm-4.66.4.tar.gz 169392 BLAKE2B 6d8e3e9775d93d9c064289b8a830b4f541a753a48044ec65fcee9c8d158d423e362d06c3404efce67de28fab2c3f1fb3d8aaa0fdec33b4d040ad1f2aec97fde2 SHA512 fdafa64784564f7f400f29ffa75ba564a3c9bc6d935a1ccd82260d4a1f4431792a9dae2d5c6ed69cc265f078f674081589a040d47b8745a500870d27670feadc
+DIST tqdm-4.66.5.tar.gz 169504 BLAKE2B 9868bcfb4f3fc22aedfbb848d383055ef6ef9795982cd7877e620dba5391ffee369c375b27555c302d1fc6fb27ddacf8d3874daeffa62e5e8699e1124fbf96af SHA512 8e2c35f02fe365063a325d8a1d3e525870d522fab465e1a86764b8716ff32c039db463fe5e74a5f080ced40851d49b1e4273126074d62f14ed1935a96e0afb8a
EBUILD tqdm-4.66.4.ebuild 1088 BLAKE2B 93923e39c2ecdab082ce71f404135ad82b654420f3b5da2f19c7f2bf5cd9b1096867604f9fa26f4f82f7cd77fbb8df8aae992bdb175c7294d269c3e99bf30cc5 SHA512 55c1a82c8e8c982fd37f1483b2e8a6bc4c62c3beb6df77c8380c84747b313e0f487b8d7dff2515d243795cada202b17e955a6b766c849dc0c098d496e9131238
+EBUILD tqdm-4.66.5.ebuild 1009 BLAKE2B 02d92de0a9b5bb85204d88555339515b7450d67dfdf2ec66736388c5a245dcc6f23b543b668060f7279df57b69efd39459b66982fbfcd021f12dc572eabea079 SHA512 8a9cb745342a1ae64a23e521b5fce3cd80a6cc721ceef5e4dbe52d2d98406a6490610d735858c0bb6fd056fb0aba6e22030020718e820f036241f47295b45316
MISC metadata.xml 605 BLAKE2B ed20e6f11f20cdc6525b98d9fd37c0b8f0781dd1c4be85e8aa4a3f5644a20fde3179bd44bb99ef4c14913168113a58963b36281ccf4807a694624a1e2df578f8 SHA512 b5f096a0256312e6ab5098bb6d9965b567bd735813d9c97fa49f08de640f2c5ebb292ba747eb284ff043dc29d4bb1cab1ac947ecaab6b4e94aa51e96a0cac636
diff --git a/dev-python/tqdm/tqdm-4.66.5.ebuild b/dev-python/tqdm/tqdm-4.66.5.ebuild
new file mode 100644
index 000000000000..8928bc3c752e
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.66.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}