summaryrefslogtreecommitdiff
path: root/dev-python/tqdm/tqdm-4.23.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
commit97967bbbae8f43c98315b079178f1717f130e302 (patch)
tree27523f8cbd75ed85f33294862514b786a30dd6e5 /dev-python/tqdm/tqdm-4.23.3.ebuild
parent30c53e395853f5bfe805a1e429fcf26666eed8f8 (diff)
gentoo resync : 19.05.2018
Diffstat (limited to 'dev-python/tqdm/tqdm-4.23.3.ebuild')
-rw-r--r--dev-python/tqdm/tqdm-4.23.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/tqdm/tqdm-4.23.3.ebuild b/dev-python/tqdm/tqdm-4.23.3.ebuild
new file mode 100644
index 000000000000..fd3e7a7aba04
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.23.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+SRC_URI="https://github.com/tqdm/tqdm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s#man/man1#share/man/man1#" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}