summaryrefslogtreecommitdiff
path: root/dev-python/tqdm/tqdm-4.19.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
commitb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (patch)
tree38e677f4a13244ca8ed29a815a0a62f943b430d4 /dev-python/tqdm/tqdm-4.19.4.ebuild
parentd37b97a25b8b10f748eead6574b01f893f140b01 (diff)
gentoo resync : 09.12.2017
Diffstat (limited to 'dev-python/tqdm/tqdm-4.19.4.ebuild')
-rw-r--r--dev-python/tqdm/tqdm-4.19.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/tqdm/tqdm-4.19.4.ebuild b/dev-python/tqdm/tqdm-4.19.4.ebuild
new file mode 100644
index 000000000000..508bef40ecfc
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.19.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+SRC_URI="https://github.com/tqdm/tqdm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s#man/man1#share/man/man1#" setup.py || die
+ distutils-r1_src_prepare
+}