summaryrefslogtreecommitdiff
path: root/dev-python/tpm2-pytss
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
commitb8325835c82367d22428eb41afa0f2d375338d3c (patch)
treec416b8853bd14fc346da5d0129843cc4a68a30a0 /dev-python/tpm2-pytss
parentd2ed973482fdd800013658e83a61709b29e0a80f (diff)
gentoo auto-resync : 28:06:2024 - 07:59:59
Diffstat (limited to 'dev-python/tpm2-pytss')
-rw-r--r--dev-python/tpm2-pytss/Manifest2
-rw-r--r--dev-python/tpm2-pytss/tpm2-pytss-2.3.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/tpm2-pytss/Manifest b/dev-python/tpm2-pytss/Manifest
index 50abc7693bc1..d1391817f389 100644
--- a/dev-python/tpm2-pytss/Manifest
+++ b/dev-python/tpm2-pytss/Manifest
@@ -2,5 +2,7 @@ AUX tpm2-pytss-2.2.1-Revert-test-skip-some-FAPI-tests-if-testing-agains-t.patch
AUX tpm2-pytss-2.2.1-cryptography-fixes-for-newer-version-of-cryptography.patch 1944 BLAKE2B b7f9e517427b2b25dc42730b7b39bf055f890b66c6f0b34e04ee495755fc98162c1af11d2520b9b08aa16396e1c574116e5ffb323ce41dbc0ab7fba4a2b4438d SHA512 ae6a8f9d544b4770a58821655cfd622cc6ed0d6e556cc40dc58097715ccf4d3fa84db82ead598409b50d73a2d63924d7519aa9ffef530456c65be1ae5ad13812
AUX tpm2-pytss-2.2.1-scripts-update-regex-for-defines.patch 1048 BLAKE2B 3d858726c61b216e5e22ed4af4ef0d34a68030d4260c15aa76f2516a3ccb130d6e6003e54fb35f8614e17751fdb91834ecd1b502825214bd29dba453c9e7ed36 SHA512 56033320e62b25a1b5da1241dd3fa8f1170d9320c575ca46a66fc255f26a9c807cd4425fada5cdd18626468281f3f9303faff4fd1e276ab2e0e2f7c1e0284222
DIST tpm2-pytss-2.2.1.tar.gz 208114 BLAKE2B fe07f38a6c19bc2b2baf079184f39d3ef28268900a35e14bfa22abb61dd956fdb286560ab6d35d66160147296e590fa3dac3d015f9919e1966f43179c1bdcdb1 SHA512 0acaa37d118d71edb123c5e88ef5af5dd78a73b0f8db15500866b6799d98e4c6107f9da1b8c1bce1c9061e9df85d735a39d9335cea65cac0e058db83aed8ad06
+DIST tpm2-pytss-2.3.0.tar.gz 213848 BLAKE2B 7e9264ab53cfe666991150fe2c0efdd973f7b58b4968b557d6494156ba4d362bd147f580f2ef50b85ac1b43cd9fc4921d71eea42d5a14b9379f82d45b6a6b536 SHA512 d0f76aec77afa773ec0ed7878a0ca4ef3b3475aa64f219d7a5afd89cbca795457536b0a9b5ffa14704200dcb35a89df36f9fc799694f7cc3cfbf98ea551628b1
EBUILD tpm2-pytss-2.2.1.ebuild 1193 BLAKE2B 8e2a9993c80247f2c5ea8bb53091062b3a1bff6facaa24c1c187bcb47a764088e29ff4204e108a5012ec92cf086b92b9072b9c81007cea642bdeddba93e7deb2 SHA512 6ab8a9f9a22fb9ba9d5248b49066c42a4b8fafb9c0776a00e56f46efb5759f536c99b661e15ecc88fa935687ae8deab618356c66dad576efdd79d2af190cff6e
+EBUILD tpm2-pytss-2.3.0.ebuild 939 BLAKE2B 662aa0b8c670ebcd516142d748683c884f1c12cc6907926a8aeaf4a61cb462816a776491e27957a6902d5b57d15059038bb66fcf951bafb3fc2b7d21c620e980 SHA512 3ac390944f2cc22bad8cf3e084fdeb93f4414b751c108d7719e08e91424c90252f4bd225a149bef8a8d3f15e451ec6547910c69a7b8491445e072148542940d2
MISC metadata.xml 648 BLAKE2B e4de9aae579210454f1a71043de7073c1aa7ead9c5acdea48ec2c8ebf5665ebb6837f198b6de49f7ae58bd1f5062ed4f8ca7092df56d8904aecd16bc226d95cd SHA512 dd87ec10b28530281c08d57d86a5004178e4eda729a43690ad4ab84effe246b34d777ec56c66d61a1e0335d2b9c1599366aa55bc58477f7c2dfa4eec5ab7d9ac
diff --git a/dev-python/tpm2-pytss/tpm2-pytss-2.3.0.ebuild b/dev-python/tpm2-pytss/tpm2-pytss-2.3.0.ebuild
new file mode 100644
index 000000000000..9ad2962b3fa8
--- /dev/null
+++ b/dev-python/tpm2-pytss/tpm2-pytss-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for TSS"
+HOMEPAGE="
+ https://pypi.org/project/tpm2-pytss/
+ https://github.com/tpm2-software/tpm2-pytss/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fapi test"
+
+DEPEND="
+ app-crypt/tpm2-tss:=[fapi=]
+ fapi? ( >=app-crypt/tpm2-tss-3.0.3:= )
+ test? ( app-crypt/swtpm )
+"
+RDEPEND="${DEPEND}
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/asn1crypto[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest