summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/tox
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest2
-rw-r--r--dev-python/tox/tox-3.23.1.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 065c9d62d533..6075a2e9fe92 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,5 @@
DIST tox-3.23.0.tar.gz 303091 BLAKE2B 609e74ea354ca5daf45c848000961782fcef59da07f815292355d72f3e5dd078e3b5909a65521a4a1032fa2bb9481fdab0e620f4882b33aa377de9764296761c SHA512 fb96cbbdbd36399036d348716f1181285184985922e0dc61b610b36e53ea79e2d8a77190aad893650bcba86ef4c57ff0f2de2813becb2a12fe0d1aa36bb27ad3
+DIST tox-3.23.1.tar.gz 303896 BLAKE2B d59160035a6412a69f9434bfb5b2b27aa9a2ebd5344b4898b677dac15dc91ab94feca67b8edde4c0ba68c8a6a12fa885091d82a088439257e9393a99e77ade88 SHA512 ec5daf106287b265d1abec8465df8ad053ecf59876038a7cb419a57e22373809e50f8131736762dc485f559363b1878abb49d909e7b6952b2e49eea77c193281
EBUILD tox-3.23.0.ebuild 2422 BLAKE2B 8e63cd0e826190ac010e09469d9c442628089f28fde6eac674e552cdc1a25d815679a79cb6ae253ce95f4747d8e5ef7f6f69de25c1354b639c11ac48ede2d6d6 SHA512 2ff7614ed21a4ed9f81f0a2323cf2095999462d0c629b824cf126bc5767a055b2044a7b947a5944e75510da1430e916a0f419c0126d518680db7b0caf71c7a32
+EBUILD tox-3.23.1.ebuild 2349 BLAKE2B f1837094eef9f7d700845729c49f9d94cf32d8acf8749c81d21393aff430262e8c08116b3a4ff80708f9e7871c2b395e0b6d47f647a668affdafff05514b254e SHA512 cd0735e3f8dcc74bef9a6ef485e29949a6d99a030275cda43999c0f3ba4fe783413454db80572cb5cd158f5dd95d2bc44dfe3842b62c5bb6cecc74f4de3f0521
MISC metadata.xml 381 BLAKE2B b690863c744dafd1aed2f7ef7b648f3abbebba225bfd14b0c977ba3def34f59a23a07d04dab8ae42d494db7ecfd8b89d4b011200e7ba4f36ecc1c81c3ae67e37 SHA512 620820cfdc3328e19da1b0e7b4db2967510de45e1fba55173474d6b0631b785ebf7e8f1441fc8411a101403fbbc0cad1f919e89563de1939cce66436546a9cbf
diff --git a/dev-python/tox/tox-3.23.1.ebuild b/dev-python/tox/tox-3.23.1.ebuild
new file mode 100644
index 000000000000..938612131f77
--- /dev/null
+++ b/dev-python/tox/tox-3.23.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# doc disabled because of missing deps in tree
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-1.1[${PYTHON_USEDEP}]
+ ' python3_{5,6,7} pypy3)
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]"
+# TODO: figure out how to make tests work without the package being
+# installed first.
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/flaky-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local deselect=(
+ # broken without Internet
+ tests/unit/session/test_provision.py::test_provision_non_canonical_dep
+ tests/integration/test_provision_int.py::test_provision_interrupt_child
+
+ # expects python2 to exist
+ tests/unit/interpreters/test_interpreters.py::test_tox_get_python_executable
+
+ # broken without tox installed first
+ # TODO: figure out how to make importlib_metadata work
+ tests/unit/test_z_cmdline.py::test_tox_console_script
+ tests/unit/test_z_cmdline.py::test_tox_quickstart_script
+ )
+
+ [[ ${EPYTHON} != pypy3 ]] && deselect+=(
+ # TODO?
+ tests/unit/interpreters/test_interpreters.py::test_find_alias_on_path
+
+ # broken without tox installed first
+ # TODO: why it can't import itself?
+ tests/integration/test_parallel_interrupt.py::test_parallel_interrupt
+ )
+
+ distutils_install_for_testing --via-root
+ epytest --no-network ${deselect[@]/#/--deselect }
+}