summaryrefslogtreecommitdiff
path: root/dev-python/tox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/tox
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest4
-rw-r--r--dev-python/tox/metadata.xml4
-rw-r--r--dev-python/tox/tox-3.2.1.ebuild61
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index 595201883f9a..84b20a47b10f 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,5 @@
DIST tox-2.9.1.tar.gz 1855982 BLAKE2B 3e2f5fd3d3e45e54f96b0a6fc8f9e98bfba3b48540cc2922a897e016b5aabc9974772c9b897e0fab7b38b00f99478a063ad988ffa8b65fa53f684997334e492c SHA512 ff19b2bb7ac963379f1cccd4973ad9eb4dabfbda976cde7caba50ad010d8fa57c1cba91d63e3e0512e44cc7d350bc9270fbd9b30db1bd55f7d9c239e7623d066
+DIST tox-3.2.1.tar.gz 268827 BLAKE2B 764835d04fb0c17f32eb8e2041b83f90d6a729b781a5b5b95e9ecb1162f1c29ed595d4a6369524b390a31853b8003485b27a3a12d63e84f49e92675f1a9bee13 SHA512 79f5a1c8f6e818fbb8444754e3767d880fc1fdfe63b46c518d37440fe2b2f3ce572865aff83d9492c24486fded49893cc31bd9b11254bac4db507260304bc76f
EBUILD tox-2.9.1.ebuild 1307 BLAKE2B 1250817a04c4eccd2471adb950ce316092b95b0d8c015a606dac2f0854ee48e32de220a5171b36e56c240a67766e6e929d8e8052a069be3651fff04d0d0ca014 SHA512 672f5fb09123ca77fc4ff93da6c00a82b02e1119ea9dcf5858792ca01b07a17ff5d0137174dbce0ffbe75b15e5c2aaf26811f412a258da6c0c22b9101202c077
-MISC metadata.xml 357 BLAKE2B bdd98bc9f7cc557df1218d1d6c6dd6c0b77fe41ac2e7133728cec5e0709059b60d778fcc958c6932996dd6776c89aeb2e5d1059ee92e8aa824296c512145a2c7 SHA512 8955a371491a0ec5c85704134be03aef40584281a4c7cc74b3d63a0820050692ac7ebeca042b8847fe415170d83dacb27bb51a1d545da0ee28e77c7e405e59c3
+EBUILD tox-3.2.1.ebuild 1926 BLAKE2B f0cd10f46ae714b4dc244428576baf1db69e65b5fd5f095ae866ebf61d82826fecef9b6a599e13dfb86dd1377b1b6805c51f468da1597acd5628d7243659a11c SHA512 9e754fce0a095f1376cd7d6b34792244f91f6feb7a7285320ffe93a5401deda4fb0d554a5a5281396ca05f52ee13e587a15343115ff9281b7d4be0536fe07b7c
+MISC metadata.xml 465 BLAKE2B eba47520bf4a2f615fbfad7c26ac19af51d6b9c0ef8dff0212a6723376b34a0d17386f05b3f4dd3ab715b9af867fabc038c300fa8df357c648dedb03efbeed88 SHA512 9bcd58c451d7196c9870a04b76a504090ec217c7c88f47f17e141c5c9519fc41d24dfc83d97eb48b935d90b621a0ada1ed664fafffd7880e91627e56259b3c76
diff --git a/dev-python/tox/metadata.xml b/dev-python/tox/metadata.xml
index 9a563f6807cb..92419b0faa7e 100644
--- a/dev-python/tox/metadata.xml
+++ b/dev-python/tox/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>vdupras@gentoo.org</email>
+ <name>Virgil Dupras</name>
+ </maintainer>
<maintainer type="project">
<email>python@gentoo.org</email>
<name>Python</name>
diff --git a/dev-python/tox/tox-3.2.1.ebuild b/dev-python/tox/tox-3.2.1.ebuild
new file mode 100644
index 000000000000..61461fa6c1a0
--- /dev/null
+++ b/dev-python/tox/tox-3.2.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="https://tox.readthedocs.io https://github.com/tox-dev/tox https://pypi.org/project/tox/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-1.11.2[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1.0[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.17[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ <dev-python/pytest-4.0
+ <dev-python/pytest-mock-2.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # remove intersphinx stuff
+ sed -i -e "s/'sphinx.ext.intersphinx',//" doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${S}"/doc/build/html/. )
+ fi
+}
+
+python_test() {
+ # TODO: find why these 8 tests excluded below fail.
+ pytest -v --no-network \
+ --deselect tests/test_config.py::test_plugin_require \
+ --deselect tests/test_docs.py::test_all_rst_ini_blocks_parse \
+ --deselect tests/test_interpreters.py::test_tox_get_python_executable \
+ --deselect tests/test_session.py::test_tox_parallel_build_safe \
+ --deselect tests/test_venv.py::test_install_python3 \
+ --deselect tests/test_z_cmdline.py::test_alwayscopy \
+ --deselect tests/test_z_cmdline.py::test_tox_quickstart_script \
+ --deselect tests/test_z_cmdline.py::test_tox_console_script \
+ || die "Testsuite failed under ${EPYTHON}"
+}