summaryrefslogtreecommitdiff
path: root/dev-python/towncrier/towncrier-23.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-29 16:55:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-29 16:55:57 +0000
commit70a061c3f38986cf8f04a4c6567114cea348169e (patch)
treef65d820de3aae87b95293bc34e6230fb608046c1 /dev-python/towncrier/towncrier-23.6.0.ebuild
parent65277f763adcb68cea58abf75cd35eab450a0d15 (diff)
gentoo auto-resync : 29:11:2023 - 16:55:57
Diffstat (limited to 'dev-python/towncrier/towncrier-23.6.0.ebuild')
-rw-r--r--dev-python/towncrier/towncrier-23.6.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/towncrier/towncrier-23.6.0.ebuild b/dev-python/towncrier/towncrier-23.6.0.ebuild
deleted file mode 100644
index 476c1deedafb..000000000000
--- a/dev-python/towncrier/towncrier-23.6.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Building newsfiles for your project"
-HOMEPAGE="
- https://github.com/twisted/towncrier/
- https://pypi.org/project/towncrier/
-"
-SRC_URI="
- https://github.com/twisted/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/click-default-group[${PYTHON_USEDEP}]
- dev-python/incremental[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- dev-python/incremental[${PYTHON_USEDEP}]
- test? (
- dev-vcs/git
- >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- "${EPYTHON}" -m twisted.trial towncrier ||
- die "tests failed with ${EPYTHON}"
-}