summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-08 00:08:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-08 00:08:11 +0100
commitadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (patch)
treed1e752b60c2ed90ae9e427cbe2b07061e3879191 /dev-python/tornado
parent941687623283212199cbe6e36f7d61b89d6222b2 (diff)
gentoo auto-resync : 08:06:2024 - 00:08:11
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest2
-rw-r--r--dev-python/tornado/tornado-6.4.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 96632611e4bd..16e90fbf2c77 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,6 +1,8 @@
AUX tornado-6.3.2-ignore-deprecationwarning.patch 656 BLAKE2B a64b3b5f021f4e1939c69f20fe93ef61eb64666b083773c1fa189af03d0964b8832a97d49ce18924f9e1202f26bb85b76d182f2baaa8265d0e1a2decbd12efef SHA512 5cd0258db519ec2a02a9988160a345c94ffb2abae92a78fb8e9d3eb6017bac8ecb86f4ef0e3eedb5ea561344213850e2b342a1f6517c909a3c6a0224606f2afd
AUX tornado-6.3.2-test-timeout-increase.patch 521 BLAKE2B 9d3b5d8a380178f84146e7909a6557c28c48df775abb96afadbe4a06a7b565d5c32f39359060fd45028120c8952238f95fca3348e225096784e806864cfd2b7a SHA512 00a964cd75224195e8de77bc7137c087c6f4128734a9c55505ef4d88d512deb0325df56e3da4c8fefac10915613e1dc244c9107123a22bc9f124fa515fae9f4a
AUX tornado-6.4-pytest-8.2.patch 2763 BLAKE2B a4f416ac403f8a1f616c7a3e2e97c74919242424d829249f302f9ecd0779f96244b33d5e17e441592d315b014c8b94ce9efef32ea54919c6b6545c3cdfa7041d SHA512 a252f8276b503f5f96f0059f3a75ca480b9f99542cf88066aff4ec020f091acb7826222441538f010a7a2ac1c0a9b423630eb8fcff54be89ef30f998d11e7e3a
+DIST tornado-6.4.1.tar.gz 500623 BLAKE2B e359d9cbf5e7311e608753a2908e61ea121e4d108209866fda49e79ecca3dc8495c35583406dd7d6b2852c4f6a9df2e340b1f4b892489be976d70000ed51aa33 SHA512 294b4fff8a6d1b9592d355f7faf78f1a94a2aaea1b54414b7e81884b8d4069713a28f6105ae36f27be78abf4c47a1fceab3801bc92b5429374f7a534f104c437
DIST tornado-6.4.tar.gz 498845 BLAKE2B ebcdcfa93490107addfe69f722e2d85058a92fc366b09a4794a4d6e0a93040ef9791095a5a94d21937d4e88dea09521644cf92d0f2c7e98238dc58e6b864a009 SHA512 c063509d4c385e410c63cccdc1e9c66aa2bb739473667ede56cb801b7379b910c8059dec831d609109f3076222b588b257afd960dffa422d7a872867dcdda7c7
EBUILD tornado-6.4-r1.ebuild 1548 BLAKE2B 2a4698ebfc560294f4c5415252194ab7708afa5f567fc22812d0cf1292a220fc8ea5590ea212c0b7d4019a32fa43464c49819bb2d96be4c8a0b2b0582c548e05 SHA512 813352059ced6a29ea25d543db2757695be0635d6dc58713d0750a6f6379778db805368200dd6dc5d2b325d2318aff670281f1cda842bfcc50af1921aaff0461
+EBUILD tornado-6.4.1.ebuild 1468 BLAKE2B e8f84c6eac59dceaaf6f353386f98ac569497cea4fa8bc25e67287890bb9b96814a4bb1b12c0381e3445940b8ef9df2c48ce84b4b531c81cf6580cc970d2505d SHA512 6e70bbf785000f171a89a16101833b4681a577e08d3b62590dcaa78e9aabd612e383a3433a4a53d6ee47e3d1f29f20fe2c48a78b8f64e1f1eb89844a8214e5cc
MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/tornado-6.4.1.ebuild b/dev-python/tornado/tornado-6.4.1.ebuild
new file mode 100644
index 000000000000..48e48fe9a958
--- /dev/null
+++ b/dev-python/tornado/tornado-6.4.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.3.2-test-timeout-increase.patch"
+ "${FILESDIR}/${PN}-6.3.2-ignore-deprecationwarning.patch"
+)
+
+src_prepare() {
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ # Avoid time-sensitive tests
+ # https://github.com/tornadoweb/tornado/blob/10974e6ebee80a26a2a65bb9bd715cf858fafde5/tornado/test/util.py#L19
+ local -x TRAVIS=1
+ local -x NO_NETWORK=1
+
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}