summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
commit662f71ae67cd775d7fbb79b5091676c0e07a992b (patch)
tree74c7cb80b79b8886cd7466cf262878d1e8b9d546 /dev-python/tornado
parentb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (diff)
gentoo auto-resync : 29:05:2023 - 15:17:30
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest1
-rw-r--r--dev-python/tornado/tornado-6.3.2-r1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index f65ae82b4cd7..75cc051f9940 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -6,6 +6,7 @@ DIST tornado-6.3.2.tar.gz 508776 BLAKE2B 10cea881365ab72290ac9bc240dc7fa4e77511b
DIST tornado-6.3.tar.gz 507992 BLAKE2B a894fbb62e4246be82b09856977758e8e55886b77917a4a23a6411a58b2b85ae1ae9113e70cc00bf0b0775566d0bda237ab3ba91ff18012c7c72f24dff587a9e SHA512 f25bbf1e489bb53ba5ed502a9241b3629a66a8bee3ba54d8bd96946e478ea06dfdf70e6f937da25c8240cb16cc5c9ff3011415503c7d03e2b1eeb2f7567d8209
EBUILD tornado-6.2-r1.ebuild 1731 BLAKE2B 4750f57886291ae09f300e20eddee0cccba0dfa07144e563a7ab9aa15879700760e511c1c9556fe4e82d6bf48036aefcfe67099dcb1261a248c538ab528f5ddc SHA512 f32d7d2078531728822b732bafcc8c738656e2a3dbba1ad9e1e6fb09346c4506d2a1814d56e95cf37780a8c8180e0b3560c791a9cb3afc1b45668b780b988401
EBUILD tornado-6.3.1.ebuild 1321 BLAKE2B b0e47d2f9d7a089e459f94531c8246e9d0cf3adf27552da3adc960286856ec6f1063270ef492012dd72b9f3f6ab192ae09fc791cf341b9b7d7e45ecf234264c1 SHA512 e4d01cceac4bf818ac8a54df022010fce75d6a27966911c57f07bfdaf07ea2b9c19352b0c6c84ac5c0e50368e54f808f4266c3c6cd3252716a4733ee1c88debb
+EBUILD tornado-6.3.2-r1.ebuild 1848 BLAKE2B f56627af6eaee0678d61dfef1132ce5e3af1ea8dbf6a61d08fd41a6c7577bb3424b42a8c73fe607c4704c629566b1ed92ab1ce566f0be49480c09cf811ecc85f SHA512 308571e7de81cc4bc9cfe854f0ed92dc9262f7b5db12d1c646690c80a302479808a0a6829bd707b217f22a8cc06262ad7d22596cdab95a7412f673f2612cbdfd
EBUILD tornado-6.3.2.ebuild 1627 BLAKE2B 470ddecffc85fcb0d06c01060da20a7000e03208ea067eff1eabe30115a5f035ab8611fa4e6de485e3e1e965881491b3f92abe842b74a09e923b9de3f24c6eae SHA512 f03fd0347c1dabff997b43fa5d33d0f9e4127fd1e4d686716be2f5d75a468729a6f4dd8ce07157361701b45ffa3cf4682cf891495eba81525458b511d5214473
EBUILD tornado-6.3.ebuild 1305 BLAKE2B abbcf9da88e6413cc75d7e6b1efda18ad742fa7c3467e691ba67bb11349c9f14c38eded49074e028f498e14af8560e1f8541290f58953d1f7992d641391fe4e8 SHA512 0e632b21bf10141731907854cb8c46c2037864e892e9c816b2fa38b02331775f0da2df3279727778a3e8c5772e5362477bac64b327f844a0af13c1856c219be0
MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/tornado-6.3.2-r1.ebuild b/dev-python/tornado/tornado-6.3.2-r1.ebuild
new file mode 100644
index 000000000000..c44ab2b97f92
--- /dev/null
+++ b/dev-python/tornado/tornado-6.3.2-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.2-test-timeout-increase.patch
+ "${FILESDIR}"/${PN}-6.3.2-ignore-deprecationwarning.patch
+)
+
+src_prepare() {
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+ # regressions with py3.12, not important enough to block us
+ sed -e 's:test_chunked(:_&:' \
+ -e 's:test_gzip:_&:' \
+ -e 's:test_header_callback:_&:' \
+ -i tornado/test/{curl_,simple_,}httpclient_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ # Avoid time-sensitive tests
+ # https://github.com/tornadoweb/tornado/blob/10974e6ebee80a26a2a65bb9bd715cf858fafde5/tornado/test/util.py#L19
+ local -x TRAVIS=1
+ local -x NO_NETWORK=1
+
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}