summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 12:04:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 12:04:32 +0100
commit5b52b99ca475070991d8e8d1dff674ffe6ffdea9 (patch)
treecf4bb45c00280387facfe6360387dbb2f8526bf3 /dev-python/tornado
parent2cf667d4c687ef89fe0fc530e2a5bc8518941728 (diff)
gentoo auto-resync : 22:04:2023 - 12:04:32
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest2
-rw-r--r--dev-python/tornado/tornado-6.3.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index dd42bf994acd..6f3fbe30d80d 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,6 +1,8 @@
DIST tornado-6.2.tar.gz 504849 BLAKE2B 18fee464e043e20dcdd5677bc3a72949140a64ce353e09a21242fcade6d8b668517553c649d65e892d9c3fabacea96903d4e42b70676a62759900abc8f4a202f SHA512 157cbeee21bef29ac68b319329e7fc57db4c68dbb5a245e2171b7a28427ebbfe16b745e3bdbdec5912caae5eaa60c3cbbf8830c9c76fec5ffdf025e234468517
+DIST tornado-6.3.1.tar.gz 508547 BLAKE2B ed7d9085f75291d341574c610b23a9a24468238988e7bd726be6da4ed8cd5588c1df5e11a154f3c9843931d210198d3bd57d3999b4bdcdf13b3b78afec04df36 SHA512 e6b33d017448060d29e718cb4ed4f852f3f1a970ef6149fcf88900cf7a7f008b737cfdad3c217a6c43a5c7176aee0adb72c3c0055b6b3faac49acd34c3b74b90
DIST tornado-6.3.tar.gz 507992 BLAKE2B a894fbb62e4246be82b09856977758e8e55886b77917a4a23a6411a58b2b85ae1ae9113e70cc00bf0b0775566d0bda237ab3ba91ff18012c7c72f24dff587a9e SHA512 f25bbf1e489bb53ba5ed502a9241b3629a66a8bee3ba54d8bd96946e478ea06dfdf70e6f937da25c8240cb16cc5c9ff3011415503c7d03e2b1eeb2f7567d8209
EBUILD tornado-6.2-r1.ebuild 1731 BLAKE2B 4750f57886291ae09f300e20eddee0cccba0dfa07144e563a7ab9aa15879700760e511c1c9556fe4e82d6bf48036aefcfe67099dcb1261a248c538ab528f5ddc SHA512 f32d7d2078531728822b732bafcc8c738656e2a3dbba1ad9e1e6fb09346c4506d2a1814d56e95cf37780a8c8180e0b3560c791a9cb3afc1b45668b780b988401
EBUILD tornado-6.2.ebuild 1682 BLAKE2B e7e538a617c514b7c76166c35a4f9f2b441ad92b36dbc6a106bea0fa4c5b9782709c0449bed34b46c38f962e7df1745a577f893b1800d25f98d66f10f31caa09 SHA512 ec776527aa1d35b8e81c2450209bfa56be94f1cc2fd245abc80c5808656745380b76a056ed115f3f180c5602f3838e7fee31f2846ee7dbde7786f8286db10d0f
+EBUILD tornado-6.3.1.ebuild 1321 BLAKE2B b0e47d2f9d7a089e459f94531c8246e9d0cf3adf27552da3adc960286856ec6f1063270ef492012dd72b9f3f6ab192ae09fc791cf341b9b7d7e45ecf234264c1 SHA512 e4d01cceac4bf818ac8a54df022010fce75d6a27966911c57f07bfdaf07ea2b9c19352b0c6c84ac5c0e50368e54f808f4266c3c6cd3252716a4733ee1c88debb
EBUILD tornado-6.3.ebuild 1305 BLAKE2B abbcf9da88e6413cc75d7e6b1efda18ad742fa7c3467e691ba67bb11349c9f14c38eded49074e028f498e14af8560e1f8541290f58953d1f7992d641391fe4e8 SHA512 0e632b21bf10141731907854cb8c46c2037864e892e9c816b2fa38b02331775f0da2df3279727778a3e8c5772e5362477bac64b327f844a0af13c1856c219be0
MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/tornado-6.3.1.ebuild b/dev-python/tornado/tornado-6.3.1.ebuild
new file mode 100644
index 000000000000..ccbe90d68266
--- /dev/null
+++ b/dev-python/tornado/tornado-6.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+src_prepare() {
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}