summaryrefslogtreecommitdiff
path: root/dev-python/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-11 12:07:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-11 12:07:11 +0000
commit44a6f923079d51164af67c7bc3f3e0db24658088 (patch)
tree887711eae2249a5c6ddbd27a28150c485e7b5475 /dev-python/tornado
parent81e061dafc8bba274946b1e96d43863977187080 (diff)
gentoo auto-resync : 11:03:2023 - 12:07:11
Diffstat (limited to 'dev-python/tornado')
-rw-r--r--dev-python/tornado/Manifest3
-rw-r--r--dev-python/tornado/tornado-6.2-r1.ebuild69
-rw-r--r--dev-python/tornado/tornado-6.2.ebuild3
3 files changed, 72 insertions, 3 deletions
diff --git a/dev-python/tornado/Manifest b/dev-python/tornado/Manifest
index 5dcb286b3357..d644a40a166c 100644
--- a/dev-python/tornado/Manifest
+++ b/dev-python/tornado/Manifest
@@ -1,3 +1,4 @@
DIST tornado-6.2.tar.gz 504849 BLAKE2B 18fee464e043e20dcdd5677bc3a72949140a64ce353e09a21242fcade6d8b668517553c649d65e892d9c3fabacea96903d4e42b70676a62759900abc8f4a202f SHA512 157cbeee21bef29ac68b319329e7fc57db4c68dbb5a245e2171b7a28427ebbfe16b745e3bdbdec5912caae5eaa60c3cbbf8830c9c76fec5ffdf025e234468517
-EBUILD tornado-6.2.ebuild 1729 BLAKE2B d0466bd0c4d8ca33dedeb0ddcf79a7aabf2fa9cb9afe836104b2f4af38aeade3a7f8fe0d1fed0e322ba1fed599fe29bc4af546cb811706111d77b6eee07af0ce SHA512 ab1784de7492c8094cc6b13027ea7c18830048098ebc17a8441b6ee6b8d841e3c89b859a923606a465900bf5c7846c4e7f3ff2f74a2ab957919add38c4ad3433
+EBUILD tornado-6.2-r1.ebuild 1739 BLAKE2B b86a8bacd43941330fde286567c7c69760a60089fc7eb540073687c1ccf344071684f552e880081d1b10013ae343a4e2bec1087a48595f5d3485f1d7027cf328 SHA512 5a56b40494b63c692fcf6d10d8e1ef8e7f127c426d2e4cbf7b635f4b5b51fa12b9890b04057db75123be9cb0b24d0107287cd73815794a5b2c14b447d901f392
+EBUILD tornado-6.2.ebuild 1682 BLAKE2B e7e538a617c514b7c76166c35a4f9f2b441ad92b36dbc6a106bea0fa4c5b9782709c0449bed34b46c38f962e7df1745a577f893b1800d25f98d66f10f31caa09 SHA512 ec776527aa1d35b8e81c2450209bfa56be94f1cc2fd245abc80c5808656745380b76a056ed115f3f180c5602f3838e7fee31f2846ee7dbde7786f8286db10d0f
MISC metadata.xml 381 BLAKE2B 96d5942b11b6364eeac2248f6e92a9e7a54094ba2b6e9ef966be4143e1fa01fa0c417027d33a71c51bb094b905b9ff79e05107e1a9debb4b1ef932ba11fd8565 SHA512 cd4db13e0c6a9cf8b3c788c53dc5ecd0dce2cf783e7b2d67dba71299d1c6a3d1dd2c2a76c0d69816ab0da4ca23f831613323c55864fd858690c605da5426bf60
diff --git a/dev-python/tornado/tornado-6.2-r1.ebuild b/dev-python/tornado/tornado-6.2-r1.ebuild
new file mode 100644
index 000000000000..0ba2105f03a4
--- /dev/null
+++ b/dev-python/tornado/tornado-6.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="
+ https://www.tornadoweb.org/
+ https://github.com/tornadoweb/tornado/
+ https://pypi.org/project/tornado/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-asyncio
+
+src_prepare() {
+ # Disable deprecation-warnings-as-errors because tornado has a lot of stuff deprecated in 3.10
+ sed 's/warnings.filterwarnings("error", category=DeprecationWarning, module=r"tornado\\..*")//' \
+ -i tornado/test/runtests.py || die
+ # broken upstream
+ sed -i -e 's:test_multi_line_headers:_&:' \
+ tornado/test/httpclient_test.py || die
+ # network-sandbox? ipv6?
+ sed -i -e 's:test_localhost:_&:' \
+ tornado/test/netutil_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x ASYNC_TEST_TIMEOUT=60
+ cd "${T}" || die
+ "${EPYTHON}" -m tornado.test.runtests --verbose ||
+ die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/tornado/tornado-6.2.ebuild b/dev-python/tornado/tornado-6.2.ebuild
index 7fbe04479120..e06b3c0c2c1a 100644
--- a/dev-python/tornado/tornado-6.2.ebuild
+++ b/dev-python/tornado/tornado-6.2.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Python web framework and asynchronous networking library"
HOMEPAGE="
@@ -15,7 +15,6 @@ HOMEPAGE="
https://github.com/tornadoweb/tornado/
https://pypi.org/project/tornado/
"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"