summaryrefslogtreecommitdiff
path: root/dev-python/toposort/toposort-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
commita87296ad796f00f3bba27339f6efe11b9a384e23 (patch)
tree1a47aa193935e1eb80c6ce1c7ececdcf9d44dfb3 /dev-python/toposort/toposort-1.10.ebuild
parent724cccb689f2076a398ede6845749926c86ea647 (diff)
gentoo auto-resync : 27:02:2023 - 22:02:09
Diffstat (limited to 'dev-python/toposort/toposort-1.10.ebuild')
-rw-r--r--dev-python/toposort/toposort-1.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/toposort/toposort-1.10.ebuild b/dev-python/toposort/toposort-1.10.ebuild
new file mode 100644
index 000000000000..8ff89edcaf7c
--- /dev/null
+++ b/dev-python/toposort/toposort-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="
+ https://gitlab.com/ericvsmith/toposort/
+ https://pypi.org/project/toposort/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py -v || die "Tests failed with ${EPYTHON}"
+}