summaryrefslogtreecommitdiff
path: root/dev-python/tomli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/tomli
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/tomli')
-rw-r--r--dev-python/tomli/Manifest2
-rw-r--r--dev-python/tomli/tomli-2.0.1.ebuild13
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/tomli/Manifest b/dev-python/tomli/Manifest
index b826cfde2a0a..43d80bbb58b4 100644
--- a/dev-python/tomli/Manifest
+++ b/dev-python/tomli/Manifest
@@ -3,5 +3,5 @@ DIST tomli-1.2.3.gh.tar.gz 123142 BLAKE2B e8af1618aa962d7ff56d319c3a789c7655d9cb
DIST tomli-2.0.1-py3-none-any.whl.zip 12757 BLAKE2B 0a33773bc0409831aec6ee803ef0ef9d6b6b441213d549184068e218b73d6178d617bc2b58d11db98f0e6284baaf81663723fbc6eb89f7466608f0d89aeb1982 SHA512 b6164b03d3db360093f92e644e87a37a0ce20d63d7e9e271fcafd727f4fdb73ad6b301aaf32b3d2839f6eedbc8ea499dafba7335b8fdfc4667e30ed50c9805b4
DIST tomli-2.0.1.gh.tar.gz 133685 BLAKE2B 0d3a1f4ee4e74eeab6a7e7c3d5e866ce1baf9017136cdc8ce1f6275f8d6d151239e5a00b97b6409872fac0e8558a49120adf16f0ae21f9d92ae630dfd39cd6ff SHA512 a467f8d48cdbd7213bd9b6f85fd48ba142ab7c9656c40bb30785e1c4b37a9e29eaed420f183458ad20112baee8413ebbec87755332795c8f02235d1018c3aa5c
EBUILD tomli-1.2.3.ebuild 976 BLAKE2B 6089f88bf9143bf531836df76bcb6a9202d2be4122474c252882d805617e9fc87de0e755e7200aa3ce362addccd4ce1f2ec263e58505c3bacd26840e603a297f SHA512 7317aeaddea22a988f790a9ed7db914867a0343c0e1e081b4ecf7a32d719b795026a34dfa6ada1f17f4a9fd0980e2128151a91e907525f25a603f31e55344ae7
-EBUILD tomli-2.0.1.ebuild 976 BLAKE2B 0e5b39be3d88f39f42a1d299ec7736867a1576ffe90c1cb7184534a9b4cfda7c1e2b867b90c56dcdc5360952ccef234fc8ac27e3d3fe0c24d6a9ab9734afb243 SHA512 4fc71a19534c9d049bb835d971aa6b4fbc274cb9fbe6fb4a52e58b0ecee253f4be4b54f5ab5e9e0e77af3888990f38304b8127608c63c9c9c6ae46f158df796f
+EBUILD tomli-2.0.1.ebuild 986 BLAKE2B da93f0ce9f160ebd1834a7bb70633494e05cd32673467b06f25da2709bbb9707b7aa6cd5aff64319eed84c9eb20e559a3868786186f52861c2c4ab5dfbd18ca3 SHA512 18f205520c77e430942577c193b00766c412420ebd748582d51fb89c81736d330810deebfddfd6f848db6a7cbf26e73a475c6d65e45d5fe878d3b9daadae0601
MISC metadata.xml 363 BLAKE2B 2c80a2c2a8959a93e392da0e03303ffdae0a3291624c284f91d747d13983cbc188d8a64f8763ea484f792d5a42e355381034f69fa0acde382779e4ae53ac2154 SHA512 42e8d4b4d1ec773b53e8e119ce6afb74acd64de998c372c6f6ab64f70713dd825420d1e1af83b5f647dc03a917b1904d65f0cd06cbddea47a33a558be2c89562
diff --git a/dev-python/tomli/tomli-2.0.1.ebuild b/dev-python/tomli/tomli-2.0.1.ebuild
index 84bca45c702b..ca6baab56cc2 100644
--- a/dev-python/tomli/tomli-2.0.1.ebuild
+++ b/dev-python/tomli/tomli-2.0.1.ebuild
@@ -5,27 +5,30 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A lil' TOML parser"
HOMEPAGE="
https://pypi.org/project/tomli/
- https://github.com/hukkin/tomli/"
+ https://github.com/hukkin/tomli/
+"
SRC_URI="
https://github.com/hukkin/tomli/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
- -> ${P}-py3-none-any.whl.zip"
+ -> ${P}-py3-none-any.whl.zip
+"
S=${WORKDIR}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
BDEPEND="
- app-arch/unzip"
+ app-arch/unzip
+"
distutils_enable_tests unittest