summaryrefslogtreecommitdiff
path: root/dev-python/tomli-w
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/tomli-w
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/tomli-w')
-rw-r--r--dev-python/tomli-w/Manifest3
-rw-r--r--dev-python/tomli-w/metadata.xml12
-rw-r--r--dev-python/tomli-w/tomli-w-0.3.0.ebuild26
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tomli-w/Manifest b/dev-python/tomli-w/Manifest
new file mode 100644
index 000000000000..b81fdfac72ab
--- /dev/null
+++ b/dev-python/tomli-w/Manifest
@@ -0,0 +1,3 @@
+DIST tomli-w-0.3.0.gh.tar.gz 61366 BLAKE2B 1ca3d50237d41fb22e8d506d2d8af3c5d9f690161a44439d3a79038bda7a67a6af9ad62b077169b5c2bdaee2110a3be5e3eec652aa8866a20c5841662f18a7e1 SHA512 618b93f2d98eee4fafe502e25f8770dc58558b25d9ec548fa5d0a6bdd8914e487fb1d16b68d138e0f8a48a6e5713c23e4d1a6daf70c8eafa27630fee05dfe8df
+EBUILD tomli-w-0.3.0.ebuild 550 BLAKE2B b04e0d74af91b4d9ecd25b9709b6423d267cbf8e2e0b94e68ceebd3ab14a1077c058268b9b71228eb3bd6b21f44b7fd6e78acfdc6844dd6b3da2de1e1ee736ef SHA512 dc680e42111bc4a14db145d9bee7fd2c153a46984cc752121384967108d2f8dc0d9fc4931f9bf43662a74fe75434ec3e459d1b7eae9ae85a5dc69d131b38dfe1
+MISC metadata.xml 367 BLAKE2B 03ee20d3019b6e8c8644f8237b6adabe1b6eea7badeede4ee2ff0ca01617c708882b6ee9a57e2f6010f3a939251244099dd2c8c3072a9570b569f833f1dd1e22 SHA512 138eb7c21f92505f08e882e4371f0025748ce722f86442d2c6cd6483620124645bf01e6af3d2c5e383bbe4647c7f97843b0fd4e298486dd0c972a2da64624aeb
diff --git a/dev-python/tomli-w/metadata.xml b/dev-python/tomli-w/metadata.xml
new file mode 100644
index 000000000000..499f307591cc
--- /dev/null
+++ b/dev-python/tomli-w/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">hukkin/tomli-w</remote-id>
+ <remote-id type="pypi">tomli_w</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tomli-w/tomli-w-0.3.0.ebuild b/dev-python/tomli-w/tomli-w-0.3.0.ebuild
new file mode 100644
index 000000000000..48aa3a6e56e9
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-0.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli_w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest