summaryrefslogtreecommitdiff
path: root/dev-python/toml/toml-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-python/toml/toml-0.9.6.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-python/toml/toml-0.9.6.ebuild')
-rw-r--r--dev-python/toml/toml-0.9.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/toml/toml-0.9.6.ebuild b/dev-python/toml/toml-0.9.6.ebuild
new file mode 100644
index 000000000000..875843eb94ff
--- /dev/null
+++ b/dev-python/toml/toml-0.9.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for handling TOML files"
+HOMEPAGE="https://github.com/uiri/toml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" "${S}/setup.py" test || die
+}