summaryrefslogtreecommitdiff
path: root/dev-python/toml/toml-0.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/toml/toml-0.10.1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/toml/toml-0.10.1.ebuild')
-rw-r--r--dev-python/toml/toml-0.10.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/toml/toml-0.10.1.ebuild b/dev-python/toml/toml-0.10.1.ebuild
deleted file mode 100644
index 08356fa1836c..000000000000
--- a/dev-python/toml/toml-0.10.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
-
-inherit distutils-r1
-
-TOML_TEST_VER="280497fa5f12e43d7233aed0d74e07ca61ef176b"
-
-DESCRIPTION="Python library for handling TOML files"
-HOMEPAGE="https://github.com/uiri/toml"
-SRC_URI="https://github.com/uiri/${PN}/archive/${PV}.tar.gz -> ${P}-1.tar.gz
- test? ( https://github.com/BurntSushi/toml-test/archive/${TOML_TEST_VER}.tar.gz -> toml-test-${TOML_TEST_VER}.tar.gz )"
-IUSE="test"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ' python3_{6,7,8})
- )"
-
-DOCS=( README.rst )
-PATCHES=(
- "${FILESDIR}"/toml-0.10.1-skip-numpy.patch
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- if use test; then
- mv "${WORKDIR}/toml-test-${TOML_TEST_VER#v}" "${S}/toml-test" || die
- fi
-
- distutils-r1_python_prepare_all
-}