summaryrefslogtreecommitdiff
path: root/dev-python/tldextract/tldextract-5.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-19 12:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-19 12:49:59 +0000
commit328b082fd6fb193da715f61a92ff9366ad562a34 (patch)
treebb1cb21fc0cdf0377ed571709e5ff4460f159a76 /dev-python/tldextract/tldextract-5.1.2.ebuild
parent06617f385b21ef2262c88f17869c15c424e67d21 (diff)
gentoo auto-resync : 19:03:2024 - 12:49:59
Diffstat (limited to 'dev-python/tldextract/tldextract-5.1.2.ebuild')
-rw-r--r--dev-python/tldextract/tldextract-5.1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tldextract/tldextract-5.1.2.ebuild b/dev-python/tldextract/tldextract-5.1.2.ebuild
new file mode 100644
index 000000000000..cb6bb0083d41
--- /dev/null
+++ b/dev-python/tldextract/tldextract-5.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL"
+HOMEPAGE="
+ https://github.com/john-kurkowski/tldextract/
+ https://pypi.org/project/tldextract/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+
+RDEPEND="
+ >=dev-python/filelock-3.0.8[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-file-1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # we don't need release tests, also deps
+ tests/test_release.py
+)