summaryrefslogtreecommitdiff
path: root/dev-python/tinycss2/tinycss2-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
commite3f21c8aff8a76afe3423721c437a088e9232840 (patch)
treefde2c1906a9787adec106c5d6b708cd60de02c60 /dev-python/tinycss2/tinycss2-1.3.0.ebuild
parent1f00990debeffd0052c194989d0a02baac23eb96 (diff)
gentoo auto-resync : 23:04:2024 - 23:59:26
Diffstat (limited to 'dev-python/tinycss2/tinycss2-1.3.0.ebuild')
-rw-r--r--dev-python/tinycss2/tinycss2-1.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/tinycss2/tinycss2-1.3.0.ebuild b/dev-python/tinycss2/tinycss2-1.3.0.ebuild
new file mode 100644
index 000000000000..05834af319b1
--- /dev/null
+++ b/dev-python/tinycss2/tinycss2-1.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+CSS_TEST_COMMIT_ID=43e65b244133f17eb8a4d4404d5774672b94824f
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="
+ https://www.courtbouillon.org/tinycss2/
+ https://github.com/Kozea/tinycss2/
+ https://pypi.org/project/tinycss2/
+"
+SRC_URI+="
+ test? (
+ https://github.com/CourtBouillon/css-parsing-tests/archive/${CSS_TEST_COMMIT_ID}.tar.gz
+ -> css-parsing-tests-${CSS_TEST_COMMIT_ID}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/webencodings-0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if use test; then
+ mv "${WORKDIR}/css-parsing-tests-${CSS_TEST_COMMIT_ID}"/* \
+ tests/css-parsing-tests/ || die
+ fi
+ distutils-r1_src_prepare
+}