summaryrefslogtreecommitdiff
path: root/dev-python/tinycss/tinycss-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/tinycss/tinycss-0.4-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/tinycss/tinycss-0.4-r1.ebuild')
-rw-r--r--dev-python/tinycss/tinycss-0.4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tinycss/tinycss-0.4-r1.ebuild b/dev-python/tinycss/tinycss-0.4-r1.ebuild
new file mode 100644
index 000000000000..fe3fda3233c8
--- /dev/null
+++ b/dev-python/tinycss/tinycss-0.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A complete yet simple CSS parser for Python"
+HOMEPAGE="
+ https://github.com/Kozea/tinycss/
+ https://pypi.org/project/tinycss/
+ https://tinycss.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+DOCS=( CHANGES README.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ rm setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export TINYCSS_SKIP_SPEEDUPS_TESTS=1
+ epytest ${PN}/tests/test_*.py
+}