summaryrefslogtreecommitdiff
path: root/dev-python/time-machine/time-machine-2.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
commit56a597689e7509193b0924a635d2022f21b1a3e4 (patch)
tree476358a5cea634edc1fb0504f6ec03b282cfb83e /dev-python/time-machine/time-machine-2.14.0.ebuild
parent57e2174dcd454b41778b7b437f88d0a9f1a6e428 (diff)
gentoo auto-resync : 04:03:2024 - 11:43:04
Diffstat (limited to 'dev-python/time-machine/time-machine-2.14.0.ebuild')
-rw-r--r--dev-python/time-machine/time-machine-2.14.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/time-machine/time-machine-2.14.0.ebuild b/dev-python/time-machine/time-machine-2.14.0.ebuild
new file mode 100644
index 000000000000..6e40b0484718
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest