summaryrefslogtreecommitdiff
path: root/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild')
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
index d2bb115a4a8c..08d8b303c2db 100644
--- a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
inherit python-single-r1
@@ -13,21 +13,22 @@ SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="${PYTHON_DEPS}
- >=x11-libs/gtk+-3.20:3
>=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/thunar-1.7.0
$(python_gen_cond_dep '
>=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
- ')
- >=xfce-base/thunar-1.7.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
REQUIRED_USE=${PYTHON_REQUIRED_USE}
PATCHES=(
"${FILESDIR}"/${P}-py38.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_install() {