summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
commit5181ced3f3566a9610b85922b083c8f84f20d78f (patch)
treed7eb288527e8bc248dd17ff874995d8bffe06704 /dev-python/thriftpy2
parent7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (diff)
gentoo auto-resync : 08:05:2024 - 00:00:57
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest2
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.5.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index 6482745d67b0..8562fa7ef5b3 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,4 +1,6 @@
DIST thriftpy2-0.4.20.tar.gz 689003 BLAKE2B b7ceb8345e984d6b3524fadff359bb125b0c94900afbfa4c3e64de7034bd816e3fd37fe721b7c35bee0c7fa7a6416ab859c2987cb66ed3fa4a66f6ca06eac952 SHA512 e06b22e1b63df3425eccdd3c83d1154413744ee387c3882d783a5168635087e6e38fd73d24c173e76854c4fe3f57631f4dd59fbb8e5b28cd380dd27d1d51caf3
+DIST thriftpy2-0.5.0.tar.gz 779019 BLAKE2B b29e5349e11e3ce3bd587a7c8212cd6def7b9b287554a068399591bb7493a5c1d0e97c9b38a64973c01d27a83d49e181aad64cb41ce9500e40b96c813caa7b2d SHA512 f4c83bac053a2f073507e38f284f981bd129ee960dc9817f3bd5795c8e9773b78fa23d49d97cb5975783dbd1f4b52f380861bf4fc32a1af795365f703856f350
EBUILD thriftpy2-0.4.20-r1.ebuild 1176 BLAKE2B 5d3d1f1a9730ff4f399693cfb9de5423548aa17347dd782dbba62c5132acb87df2293e1e21b9d692e21ffa87260c8ded6c55cee6f29eae88f085e00830f1f57c SHA512 f4bbe67acb24026583734c0ba12fcb2faf9f099a0013b6b0837bb2779ccf439a1842af08e3a14ca9a2eb84e0cb8d258b2c806ec894395af8ffdce99cba95a69a
EBUILD thriftpy2-0.4.20.ebuild 1138 BLAKE2B 5057bde410eda482f0c3afb952865897feabfc85ac176f88489f3daa4e195e57b3d560595a99eb06d02dc6a29f9c17d0718f2326157373f6306da64b15c2cb48 SHA512 3c772cd330a5a50572f14f8fa8f9d4d03f7c9b196608a21da4765bb45dd8e2f76c868ae62ef94337d158a5e6e0d0b2f568b927d483a0b3e8251277f780579f1c
+EBUILD thriftpy2-0.5.0.ebuild 1138 BLAKE2B 608c3b65d33168f07eaf2368b6e1840a38a62a2ea5c26830448ea7fd075d4e1fa1cbe4664b85d214e4632bb089de4717558c1c9451c84638ed8dfdb8a106fe70 SHA512 5659da4f1e594793c16b1c6c3ee69aee36a9cec27473b9fc069541b4077f74b54aef31696d6709139b1c1c9c031f99b23c0bd6108ba2816e4d9da0dd9899cefc
MISC metadata.xml 380 BLAKE2B 570746c7985eab098e590e49d267c406ce02cbf612dda6bf2a60439aee62cbf6eefebac14af29bf5fa52c8b5fd4846b2872beb7034364abb722f706978b55987 SHA512 d20d8641eea699cfa6d1930b8c5a9a8edfe76b5ef837551c52105d2fe8d70d481862c5d5cdbe389971588b3bdf62e9fb7e1cec2e89d635650cbabed7f7f53070
diff --git a/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild b/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
new file mode 100644
index 000000000000..bb893082bf0b
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 flag-o-matic pypi
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/857105
+ # https://github.com/Thriftpy/thriftpy2/issues/246
+ #
+ # Don't trust this to LTO
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}