summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2/thriftpy2-0.4.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-28 23:35:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-28 23:35:57 +0100
commit95ea6b4d5731b3430396be650fdb3d4b21cebba1 (patch)
tree8fac22db6af2c5c90106b07a31ee4bbb1ca5faae /dev-python/thriftpy2/thriftpy2-0.4.17.ebuild
parentbf3704584a111859229f36449fbc925a5a19dc0e (diff)
gentoo auto-resync : 28:09:2023 - 23:35:56
Diffstat (limited to 'dev-python/thriftpy2/thriftpy2-0.4.17.ebuild')
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.17.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.17.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.17.ebuild
new file mode 100644
index 000000000000..f4882f38def2
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}