summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 09:25:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 09:25:48 +0000
commitfc2c8b325a27d1dd0e181a50517601b4fde8aa7f (patch)
treeef1849fa20636bdbda9fa704f3bfba6ee73bd418 /dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
parent7db983f17e59dfa621d994bcbdbddc71a6e70a57 (diff)
gentoo auto-resync : 09:11:2022 - 09:25:48
Diffstat (limited to 'dev-python/thriftpy2/thriftpy2-0.4.15.ebuild')
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.15.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
new file mode 100644
index 000000000000..f9d60e1c27f2
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.15.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+SRC_URI="
+ https://github.com/Thriftpy/thriftpy2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by modern OpenSSL defaults
+ tests/test_rpc.py::test_clients
+ tests/test_rpc.py::test_void_api_with_ssl
+ tests/test_rpc.py::test_string_api_with_ssl
+ tests/test_rpc.py::test_huge_res_with_ssl
+ tests/test_rpc.py::test_tstruct_req_with_ssl
+ tests/test_rpc.py::test_tstruct_res_with_ssl
+ tests/test_rpc.py::test_complex_tstruct_with_ssl
+ tests/test_rpc.py::test_exception_iwth_ssl
+ tests/test_sslsocket.py
+
+ # TODO
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}