summaryrefslogtreecommitdiff
path: root/dev-python/thrift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-30 00:07:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-30 00:07:18 +0100
commit0e2a727aba684f1a44cc0402a3f77d242140681b (patch)
treead462b91afc9d7f8d76e3c51331517fddd6b25c2 /dev-python/thrift
parent5c4786a868bad6e3f46aecf32ad6c6dc5de98408 (diff)
gentoo auto-resync : 30:05:2024 - 00:07:18
Diffstat (limited to 'dev-python/thrift')
-rw-r--r--dev-python/thrift/Manifest2
-rw-r--r--dev-python/thrift/thrift-0.20.0.ebuild19
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
index 2d254074c446..3aac8735db48 100644
--- a/dev-python/thrift/Manifest
+++ b/dev-python/thrift/Manifest
@@ -1,3 +1,5 @@
DIST thrift-0.16.0.tar.gz 4085114 BLAKE2B 17c35096f6848fb0795e4cb125fed3068c8e1e53f67f404f4dcab67df7a42fc049a7d615591c861eb9e59e3333e21f185e8615663008bc7c846a03722ea8b834 SHA512 468fff6be2def85959fdf8adac92a0cfa7f786083b3bafb2c31427dfe5725f4d10962052d13ea960828f6a317778d35e66b602744a570212352bfc637ae586e0
+DIST thrift-0.20.0.tar.gz 4397667 BLAKE2B 23422fdcdf7e0dbce8bc0f8017f54b5848594e2da21de56834152c17c74da7d1c4df23c5b57cf3ba811bb03f1a8588ddf1c2a05222bb726aceda4292a15af21e SHA512 8dc77f666e60141a6b3cf7ee1407b08a0e80d176f8ccfee69317d7df89ab87aea2c7b3ba3e59d4561835edf1ce23762443ad5aeed0099bf075b010853d5eb1cd
EBUILD thrift-0.16.0.ebuild 507 BLAKE2B 561113c01b24c4be300e203f30e8e915fc09bb44322942d055756c4159924d861d863233a678c8b033d8dc708c09499e2a4b570dc89eeb13e04987aab3d861e0 SHA512 1461f864333b6e370396a303d91b6dce199b4ed72b44d1f83ac31d82614c6d88baa4ff71502def7d5dd7bc794c6886d36b54c7b1b8a7fcec678d4246e9cbd0d9
+EBUILD thrift-0.20.0.ebuild 525 BLAKE2B b6a05752e62bfeb1b8d55fb526676bdc4f4120ced18fdb02b4b4e0bee6758bc291b6255d37e759aee74b8f9bbc41c6494d84d132a8d2f5ba0a778677e2cf161d SHA512 37770aad4e54a805289a99e88fbb0f73e56ec4b1ed649f93a488caf91370ff17408b94380a9b42abc80d57ba30bbb277e9cf8aa01ef0eb8b05932734b01e357c
MISC metadata.xml 242 BLAKE2B 596db24feba344a0e7769c630c5ca6e6c202b3fb0cbce6953b35f226ab69a90231fdbf5960aeee0e9cf4454410ba1d6ddfb626356a7d7357364f62b9a879cec3 SHA512 4df20feff33bace5d431d74b36b2b3a3f1d76bc9352665c7a8ce054521c52b18cfb4613e8b7e101d69fe5c3e2d5af9eb63f6476d020ba8f3fd6f021405a941db
diff --git a/dev-python/thrift/thrift-0.20.0.ebuild b/dev-python/thrift/thrift-0.20.0.ebuild
new file mode 100644
index 000000000000..e8532ee0c610
--- /dev/null
+++ b/dev-python/thrift/thrift-0.20.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="https://downloads.apache.org/${PN}/${PV}/${P}.tar.gz"
+S="${WORKDIR}/${P}/lib/py"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"