summaryrefslogtreecommitdiff
path: root/dev-python/thrift/thrift-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-python/thrift/thrift-0.13.0.ebuild
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-python/thrift/thrift-0.13.0.ebuild')
-rw-r--r--dev-python/thrift/thrift-0.13.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/thrift/thrift-0.13.0.ebuild b/dev-python/thrift/thrift-0.13.0.ebuild
new file mode 100644
index 000000000000..b2f881814cc9
--- /dev/null
+++ b/dev-python/thrift/thrift-0.13.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}