summaryrefslogtreecommitdiff
path: root/dev-python/thrift/thrift-0.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /dev-python/thrift/thrift-0.11.0.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'dev-python/thrift/thrift-0.11.0.ebuild')
-rw-r--r--dev-python/thrift/thrift-0.11.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/thrift/thrift-0.11.0.ebuild b/dev-python/thrift/thrift-0.11.0.ebuild
new file mode 100644
index 000000000000..bbc8f37a7dd5
--- /dev/null
+++ b/dev-python/thrift/thrift-0.11.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://thrift.apache.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"