summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/threadpoolctl
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest2
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index dd33c0d4258c..956ada2cd87c 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1,3 +1,5 @@
DIST threadpoolctl-2.2.0.tar.gz 25875 BLAKE2B 4fc77efb181a91888d2d47cf1f9fa67157366e3ce33a958244b606019389624e83b1903581bfe88f8b4c798b4a8f07d0a50269282efaa323d3cae9f3d5ea8258 SHA512 edc310a9447b1782cedc98aadd065ce9291eca04518f6223090c1dd57f714b85f32293f16cfc1d95639130db47aa04806cac77a42922471e07582293416450fc
+DIST threadpoolctl-3.0.0.tar.gz 28486 BLAKE2B e49bf43ea272e353e1a5f864cd7f38978793489b2dba60a1c075a61f6dbfe0a75a456e1143c0f33d3222ff2e27c1ce6025579b00e3feb2d789c7be068f6e07ad SHA512 df0829d5bed15d5cbcd502810aff91c9dd0d4dafc11173aa762426e96a7ed5acb0fd3132161e5b2d234136156f2a599c3592fc0a8e20828db83882b840a939cc
EBUILD threadpoolctl-2.2.0.ebuild 584 BLAKE2B 9c5699e69e84342ad78426f15fc4c4afb0904af8c9dad681235b00ddda8e4b4400b9bbb52c1be7fd41dd8e27c0275503dd44dc7a4ba866c570b138aa72ae2a74 SHA512 b9f71b88573b13398448e2405a19b53a3a8deb2600b26fbde3ac72f3e154f1d480bc262a115ac085d119e2b9ce8b1ba58b8164bbb9e48eab2943f5f1069e6005
+EBUILD threadpoolctl-3.0.0.ebuild 587 BLAKE2B e35081daaa4cb8024ad31b3f257fe5bda03de31b83755efd5b18db0e38252520fdf76577d4e4beddb1d70583d395185bfe329ec35ffa6ec07d1cc222f4752351 SHA512 500db06b5f0d52ccd8ff0a63b817ac4b89367606f4b317a124b86feaa4d138abe38e46dabd3d3a600f55174ee72996edaebbd81cd496fedbbb6bce1b7cd7b14e
MISC metadata.xml 429 BLAKE2B 85d3a98dd9d79c2e11cc44fd2e474d1278ce744a8c36887e9d458125eef41a231cce19ddd8b9fbfdb605ed9e5c5c7bbf35f2844cdbb7d7e557693ded1c1663bc SHA512 f7d15360b5cec34491ea88db7919aeaa0c353bbeed2958a25c34aa93b23a9fdd97c8c910f2623454eb78d74766e0aecde58852b9528dfd0f635ea5c6aeb28f8b
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild
new file mode 100644
index 000000000000..4e259103e370
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest