summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-21 20:41:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-21 20:41:46 +0100
commit2518522472e5de9c52c78dc0246475fe0ae3cc05 (patch)
tree75e45cd85194021231c22ad696e2900ab56b8f15 /dev-python/textdistance
parentcb701a27e552fb85d830f305bee3e17cddae0234 (diff)
gentoo auto-resync : 21:08:2022 - 20:41:46
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest2
-rw-r--r--dev-python/textdistance/textdistance-4.4.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index efab72134ed3..85b49fbfbfdb 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,3 +1,5 @@
DIST textdistance-4.3.0.gh.tar.gz 45535 BLAKE2B e43ae62b0b7656a6c4f879b1d8e0c34ae6c83705d324aa99bb7ff6e2d0166faf1fed3ee7bc06602388c16c742a1983a4eaee143b09a7c371b9e941d53edca2b5 SHA512 30d68048b1f0b79e584f5f07731e03193af64cb2de3f52882c17154cc027f4ff8d590b994941bd5d62642d4da334ef0739d4bb65b6b12f039a1ee9aef154cde4
+DIST textdistance-4.4.0.gh.tar.gz 45542 BLAKE2B ae144cb7179b589f4106ea378e538e0d0240e6e2ac74dc5de8222ec2f671fcd09c4705cb5b30308fdb2f6071578d337c0f88983511229d9f7eb86c924d65bf56 SHA512 727696b76ee8fdfc9bcf028a93baad38882893f62612fa08725e5e8cd104b9450977e3682995c4aa7d997afcc8fdb73e3c72ea6c1a097a9a19dbce98957d4798
EBUILD textdistance-4.3.0.ebuild 823 BLAKE2B ca9eb7697c93acb7b5776287b90ca426976b9573cc6d0fa0818a825dc95890137134d2330daee415a0993b8b46396e4bcc5f39f44ee484100fa3f200c98f4889 SHA512 59c71638a315ba2760da220f3a19a4f11179d5f9ad95ff93ebed6a4493b768cdb94b1d95746bea7108d41649f68f5e1f3e8ec5a20aed934273d31bcf4633b679
+EBUILD textdistance-4.4.0.ebuild 847 BLAKE2B be78d3030e886a6b8b0992e04b4f55e60cc84853a044f885c1b6d52488cf81a6804a5384821c2c1744c6e9dfbc3015dd7de50c792d04e8c37117f49568059eb1 SHA512 da247618f6ccb12e34cd3f2d1681ebeeca1a6f85abbd12e7c9cb2e9bacafc4145c9ea65ae6ebe558be84ebd3b5d4a54cae7801b2f511091bbc53333bfd7021af
MISC metadata.xml 517 BLAKE2B a429684151f5700f148c5350b16026e797fdedc80b950d3c79c050a4d7418763918a05936eaeeed07b9756d9ec39602128570cd8c27049234bbda27e006ff00f SHA512 be445c2c21f5fd0bee241f8f76094b51c2fcbd7fe0d2175f7455beb881c3b83e8070c8a14817695d2b7a7dfabcdb856e12d7749aadc91ca31f7af8187e9a409e
diff --git a/dev-python/textdistance/textdistance-4.4.0.ebuild b/dev-python/textdistance/textdistance-4.4.0.ebuild
new file mode 100644
index 000000000000..6b3f959525b4
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)