summaryrefslogtreecommitdiff
path: root/dev-python/textdistance/textdistance-4.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-28 23:35:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-28 23:35:57 +0100
commit95ea6b4d5731b3430396be650fdb3d4b21cebba1 (patch)
tree8fac22db6af2c5c90106b07a31ee4bbb1ca5faae /dev-python/textdistance/textdistance-4.6.0.ebuild
parentbf3704584a111859229f36449fbc925a5a19dc0e (diff)
gentoo auto-resync : 28:09:2023 - 23:35:56
Diffstat (limited to 'dev-python/textdistance/textdistance-4.6.0.ebuild')
-rw-r--r--dev-python/textdistance/textdistance-4.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/textdistance/textdistance-4.6.0.ebuild b/dev-python/textdistance/textdistance-4.6.0.ebuild
new file mode 100644
index 000000000000..94caef6d9024
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_external.py
+)