summaryrefslogtreecommitdiff
path: root/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/textdistance/textdistance-4.2.1-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/textdistance/textdistance-4.2.1-r1.ebuild')
-rw-r--r--dev-python/textdistance/textdistance-4.2.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/textdistance/textdistance-4.2.1-r1.ebuild b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..3628185a3371
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.2.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="https://github.com/life4/textdistance/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/${PN}-v.${PV}"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # RuntimeError: cannot import distance.hamming
+ # these optional things are missing at the moment
+ sed -i -e 's:test_compare:_&:' \
+ -e 's:test_qval:_&:' \
+ -e 's:test_list_of_numbers:_&:' \
+ tests/test_external.py || die
+
+ distutils-r1_python_prepare_all
+}