summaryrefslogtreecommitdiff
path: root/dev-python/testscenarios
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/testscenarios
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/Manifest4
-rw-r--r--dev-python/testscenarios/metadata.xml1
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild (renamed from dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild)23
3 files changed, 19 insertions, 9 deletions
diff --git a/dev-python/testscenarios/Manifest b/dev-python/testscenarios/Manifest
index 5a0f60ea5242..8a9dc229cf90 100644
--- a/dev-python/testscenarios/Manifest
+++ b/dev-python/testscenarios/Manifest
@@ -1,3 +1,3 @@
DIST testscenarios-0.5.0.tar.gz 20951 BLAKE2B 154915281456aad3353e144ffec8404514622fdeb8d2129ba530d3d5a02814599c2fead9dc25ab4904bad68b2892a435f9cbbcde92503d71477624bbec154f53 SHA512 f08b868babf504482369c5cb945d3e95bca1cc00f92d5013f6898c488051be0c26dc49aaabcef362aea45450a8d041d9826fb6b5c848beec013fb102d6935521
-EBUILD testscenarios-0.5.0-r1.ebuild 765 BLAKE2B e55ea9b94767db3614a172f49b10746adaabfdb74dc1114e31cd8e9fa51a7496cb1594401ce17f2fca03a47b5d8f4199b025ff7572c8855aa531e8d7624721b6 SHA512 a5a732ca6d62fbc4fbc5dffbbb94b1e1530d9072c3ed6676d2dbef0d30fed4bcba91275e036365eb4d87a0107cdf9d5554e94c64e111d8741389f2c4d3d6ad31
-MISC metadata.xml 980 BLAKE2B 2cc14564ee68d2ae042db7ec07616d1b7dc2b8355183c81111c965e73be351cfd49f8c23e1d60828b714d308297134e712be0cc0e5b1bb6b98eacd35ac753bdc SHA512 6de28a56b63cf6d191c6875cfc1e3cea247bb3ebfa7fc4b8bc19283317bf01f9451b08f175d30eb3e07f225932a3eebae7dd4f85d319472b77e85666e4940f24
+EBUILD testscenarios-0.5.0-r3.ebuild 919 BLAKE2B 42cd66967e984387cc358fb3331f748fd73721d2aa9e308eb2835e87e98609d55d88538701838e7756d5b738baa3c3bdbdd64273ff004664b4130fcfd1f483bf SHA512 53dbb18dbc673bd5ea4d4623bed96ad9440c98c0ce7a519fae1be0fa11ad1a39bc6163daaf6d8100734fa96db91c6eb3497068fb10637d7a9727c0110f330367
+MISC metadata.xml 1004 BLAKE2B 0c59a0b59cfd0cdca9e8460cb677511978561762c224c0583ad02e21b88d0a1aa0a1973273e71f6dfc7de372155a4e6eca9c14747e8c0749cd513ec921ec0b1b SHA512 23f6bb47cd7ed020626309ff41c94929c4cc136ed68be7ff8c45db7f28901bd575e5585a2c5aa0c06c04134edeb184f8034cea5756c4919635f76c744f9d0235
diff --git a/dev-python/testscenarios/metadata.xml b/dev-python/testscenarios/metadata.xml
index c9c0112cc913..97c52ec91adf 100644
--- a/dev-python/testscenarios/metadata.xml
+++ b/dev-python/testscenarios/metadata.xml
@@ -20,6 +20,7 @@
dependency injection (provide tests with dependencies externally to the
test code itself, allowing easy testing in different situations).
</longdescription>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">testscenarios</remote-id>
<remote-id type="launchpad">testscenarios</remote-id>
diff --git a/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild b/dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild
index db9786403f7e..c443176e7cab 100644
--- a/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild
+++ b/dev-python/testscenarios/testscenarios-0.5.0-r3.ebuild
@@ -3,11 +3,17 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="A pyunit extension for dependency injection"
-HOMEPAGE="https://launchpad.net/testscenarios"
+HOMEPAGE="
+ https://launchpad.net/testscenarios/
+ https://github.com/testing-cabal/testscenarios/
+ https://pypi.org/project/testscenarios/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
@@ -15,14 +21,17 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
RDEPEND="
- dev-python/testtools[${PYTHON_USEDEP}]"
+ dev-python/testtools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+"
# using pytest for tests since unittest loader fails with py3.5+
BDEPEND="
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
-python_test() {
- epytest --deselect testscenarios/tests/test_testcase.py
-}
+EPYTEST_DESELECT=(
+ testscenarios/tests/test_testcase.py
+)