summaryrefslogtreecommitdiff
path: root/dev-python/testscenarios/testscenarios-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/testscenarios/testscenarios-0.5.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/testscenarios/testscenarios-0.5.0.ebuild')
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
new file mode 100644
index 000000000000..81df8618ccee
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-python/testtools[${PYTHON_USEDEP}]"
+
+# using pytest for tests since unittest loader fails with py3.5+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Remove a faulty file from tests, missing a required attribute
+ rm ${PN}/tests/test_testcase.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}