summaryrefslogtreecommitdiff
path: root/dev-python/testresources/testresources-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/testresources/testresources-1.0.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/testresources/testresources-1.0.0.ebuild')
-rw-r--r--dev-python/testresources/testresources-1.0.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/testresources/testresources-1.0.0.ebuild b/dev-python/testresources/testresources-1.0.0.ebuild
deleted file mode 100644
index 255cfc70b5da..000000000000
--- a/dev-python/testresources/testresources-1.0.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A pyunit extension for managing expensive test resources"
-HOMEPAGE="https://launchpad.net/testresources"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
-
-python_prepare_all() {
- sed \
- -e 's:testBasicSortTests:_&:g' \
- -i testresources/tests/test_optimising_test_suite.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbose || die "Tests failed under ${EPYTHON}"
-}