summaryrefslogtreecommitdiff
path: root/dev-python/testpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/testpath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/testpath')
-rw-r--r--dev-python/testpath/Manifest4
-rw-r--r--dev-python/testpath/files/testpath-0.2-setup.py.patch28
-rw-r--r--dev-python/testpath/metadata.xml17
-rw-r--r--dev-python/testpath/testpath-0.3.1.ebuild49
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/testpath/Manifest b/dev-python/testpath/Manifest
new file mode 100644
index 000000000000..0f334b058f5f
--- /dev/null
+++ b/dev-python/testpath/Manifest
@@ -0,0 +1,4 @@
+AUX testpath-0.2-setup.py.patch 944 BLAKE2B 4a65d8a99fa04115e4e24f91be2b32a5f26a26b1b8fa795472622efea1afa6d5df717c10fbfbf106180d1f6d5f8822350d9605de41fc7db9e37a7b4c7b887df9 SHA512 c27c2dda320d2c16239eb498b2f59f85746745ce1875879a17f41235081983fd1015f0dfd182c6823b998f85aaf460486a3ac6d955be969487692ed50c5648aa
+DIST testpath-0.3.1.tar.gz 91333 BLAKE2B 86787b9677e8baa6d45fb5e6f047f2ab448e385201f20af3a3a9f33d6edd6c67e4eec09c178e815626096ad77d417ef99ddee562bf0fd7947b3f7ae1862f8156 SHA512 ab826cfb76d9a3ed6f1b178240f6bf61439bd792be26b5ad407b5c3efaa455b48965ceaf17e4ca6a4bc706465a8ed1c6c31a1572df5beeea2bb8db7814dc04f0
+EBUILD testpath-0.3.1.ebuild 1075 BLAKE2B fc8afc03f456abd955fbf17acf7a650b239207e94ab1248ad2096af281f8e106ee690ff25c8be070285b059a815840f8b012ff1d7b9f58eb7ae2033427ce671d SHA512 144e4f1425e5da5274f9c05b27586beab55721087f81c55ccad1b32a32ad2f0d7c773449315bb05dc366ac77409c3e4f5bfce7737b38b6a1b2485ffa8139d42b
+MISC metadata.xml 613 BLAKE2B 46ccd59fa5e42a573ba9fe1219a5e5a103876ef3e73363b3e003f76fce1138b7f6a9ef3a023be5b695bbbc1244c047d3f70b23b553b3412695a9791dac83c540 SHA512 c251993ded801317c638b460520800bc7fee9390a3c581c01a463da661eda3c7348117aa98c19efd7eb577666dfe580fc690e2f30d2001bd98e49f2baa33248e
diff --git a/dev-python/testpath/files/testpath-0.2-setup.py.patch b/dev-python/testpath/files/testpath-0.2-setup.py.patch
new file mode 100644
index 000000000000..a1bf41acd352
--- /dev/null
+++ b/dev-python/testpath/files/testpath-0.2-setup.py.patch
@@ -0,0 +1,28 @@
+Patch to bring back setup.py from
+https://github.com/jupyter/testpath/blob/086bd1bd1ec7da1b3dacfed1705c0c99fae231b3/setup.py
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,22 @@
++from distutils.core import setup
++
++with open("README.rst", "r") as f:
++ readme = f.read()
++
++setup(name='testpath',
++ version='0.1',
++ description='Test utilities for code working with files and commands',
++ long_description = readme,
++ author='Thomas Kluyver',
++ author_email='thomas@kluyver.me.uk',
++ url='https://github.com/takluyver/testpath',
++ packages=['testpath'],
++ classifiers=[
++ 'Intended Audience :: Developers',
++ 'License :: OSI Approved :: MIT License',
++ 'Programming Language :: Python',
++ 'Programming Language :: Python :: 2',
++ 'Programming Language :: Python :: 3',
++ 'Topic :: Software Development :: Testing',
++ ]
++)
+\ No newline at end of file
diff --git a/dev-python/testpath/metadata.xml b/dev-python/testpath/metadata.xml
new file mode 100644
index 000000000000..cba9cbf64b00
--- /dev/null
+++ b/dev-python/testpath/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Testpath is a collection of utilities for Python code working with
+ files and commands. It contains functions to check things on the
+ filesystem, and tools for mocking system commands and recording
+ calls to those.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jupyter/testpath</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testpath/testpath-0.3.1.ebuild b/dev-python/testpath/testpath-0.3.1.ebuild
new file mode 100644
index 000000000000..bcdf26e59fa0
--- /dev/null
+++ b/dev-python/testpath/testpath-0.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc ppc64 x86"
+IUSE="doc test"
+
+DEPEND="
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2-setup.py.patch )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
+ py.test || die
+}