summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/testfixtures
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest2
-rw-r--r--dev-python/testfixtures/testfixtures-7.0.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index cf5273ace072..7a316796ca07 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,3 +1,5 @@
DIST testfixtures-6.18.5.tar.gz 124944 BLAKE2B 6f1431b3e7201a3c12bf683cfcb123329b186f42a64fdfe3ee7897ab0c5e9ba3995deb88934ae59f0d35b64710ac04b421d07f1c496429b18a0b6a03e600885d SHA512 4d4ec7295bb056102995dc1c872b86059109b114ab921769d3aa2c2de96a3789fef30558f51826655b6d2d668ea1b1bc9f161a4584aab628f59d4da1fa95940e
+DIST testfixtures-7.0.0.tar.gz 126163 BLAKE2B e9f31180878e7645a62b93242344c6cd8335067cf8158b03dbfb46b4ab79d57380809a20d6fdc6a6d4b0aca2d22f5d7c18636607a54c70de4bea39e79a9df6b1 SHA512 5fe56e0a654586c266aab5cebcdbf1e6b9988227605395c3198c759759be0fa98ff3c0a1885711ede5ef6d262a60cd19a29dc6e7a90a1f9f8b57df3cb2d9b97b
EBUILD testfixtures-6.18.5.ebuild 1308 BLAKE2B 5c215745d5c2fda7dd17e2652f3ba0b48408312ac1c451c965b774064b0bb8e67f0d46da61815a4da1e1d401a067450905d3ba0c43def2c80f48f9f0fa5a528b SHA512 cc95fe44a119ec66e3b3b7ffb3559f2b217f27a529c649692a7264d5fc185d5e5d08d714f6dc03397767eba0a6ae5af571096bdb1c0b93bd6dbb5fa3a0c957ca
+EBUILD testfixtures-7.0.0.ebuild 1312 BLAKE2B 1080faecee935533c3477f6e7757e38e337babe3aecc67b3163a89c38f992df1b6ebc611905a79d147c3794a1ad555e467b27060ac509463b0ab35968656f786 SHA512 1bb689497c182537d7c7041311634895a1608836a029b2d82aef7ab3240ea9c259cda6971189628470e0992cd8b0f3017f95e591a03cf9a05fcfa8cabcbdabe2
MISC metadata.xml 416 BLAKE2B 19f5d275458874364d2719ecf363f7a5627f9e612b7d3a3f2c075e306063ed899dec0b2e59ea5e5d7ba65209c9a6d91045d80b2fe50e74278e61247d0426b940 SHA512 8a5776feee4d6758da67dc0b413e2d0ddc0c843075ca96c9b44adace1f7669a6abf820c5b73b86652b27e9feed19a4a30e1004a021b24bda0829b5690a1687ec
diff --git a/dev-python/testfixtures/testfixtures-7.0.0.ebuild b/dev-python/testfixtures/testfixtures-7.0.0.ebuild
new file mode 100644
index 000000000000..8d96b3520597
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-7.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/
+ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}