summaryrefslogtreecommitdiff
path: root/dev-python/tenacity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/tenacity
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest5
-rw-r--r--dev-python/tenacity/metadata.xml19
-rw-r--r--dev-python/tenacity/tenacity-3.7.1.ebuild27
-rw-r--r--dev-python/tenacity/tenacity-4.4.0.ebuild27
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
new file mode 100644
index 000000000000..e3a047408c5f
--- /dev/null
+++ b/dev-python/tenacity/Manifest
@@ -0,0 +1,5 @@
+DIST tenacity-3.7.1.tar.gz 22915 SHA256 86cae49f4334277164b97a1871828e9173d669b9bb223de44ba8c1cee787bbfa SHA512 83f277da3ee7beca4d564610a4ef46c33a87590214a41c0c36c9bb46920e5e8e7e8a8d130dcaac2802d058f7e995fbe01e13d5b7a65821e9a1e83072b78e3f00 WHIRLPOOL c8747efea73d5fd966cd448dc3b2d33341f0ed2a53287df2fe98b0a587522b984461be07159e5b0817b60650e3cfafb0a6e673d1dcd96b7c138782728c75df63
+DIST tenacity-4.4.0.tar.gz 26133 SHA256 9c5554b494dd8bae998dbffd7b8d1876e6b94de0c1df1ac51d0db25bb9f830b2 SHA512 08f4eef91e38f8d166029625e337057bd9a934fd58473d8c3666436e6312a0f7dd7f24dea05c8427df627bd37c7003602089970079f214fa7b79beee64df3f96 WHIRLPOOL f12433c89c0a4b2139be4d74dfb3812dcde9dae7feec9517d9287f85313fbe86567a1b9f9c3f55c1b4b864a84eaaac5097cc440dbffdb01a6425c0ef647b259d
+EBUILD tenacity-3.7.1.ebuild 633 SHA256 7ae13bb184e715025adbab3a8d0798389079405930be1f2c3980b3f6e5994347 SHA512 e5272ba1165543af1d3d09b3a4c97b49527c022da7ee408a0d15e2b58800f7635c8b418913d2e668adc3eed25b0d2416c657f998937d7c3fd4c05a07c893cb63 WHIRLPOOL b801919a49996604453ac02a38be05716173071c3a90c170d10b3419f553316d6726526c329ffa9985757a3726a8df600dd64d8047c8f778cb5d717568209418
+EBUILD tenacity-4.4.0.ebuild 623 SHA256 bec60593862a17ef893648958dbdec4bd5d04b7321dd9a282b89d45425e38723 SHA512 e3058bbd3c3a2103f245b98ddf4bf77c4bc2e422bd6a0af56dd9a7efbf773069f0cf89a3bccb155d7e667e16b533793b68e2f4f7aeecf74f29d136d5ebc26e38 WHIRLPOOL 52f275ef2a693e9ad64eaeddd0de57f6bdd98818db76dc9ec7f5b06d6f8ac0ee1dfb5bd1b57641773a7729e85080d0aac0656ce56a65874988079b347b692dad
+MISC metadata.xml 730 SHA256 378acb70f8be2fa879f47661dab7f219b8da7612d12a36ccb8d809a21a62ef19 SHA512 0b355562b481aebb7daf0940cc5548dc33e8252ae39e8bbd811f957f6253aa481c0fd02fefb7b30672392af50d5aa69731767915d47cbf83b71788cf8f5a6144 WHIRLPOOL db2c1c6ba46f231772071c938e3c977eba962b47b65122fa469e3ff40b8408914e443225536cf170fe9b23a6abb5c0176b30fef6749122e6f1197fdfb433b865
diff --git a/dev-python/tenacity/metadata.xml b/dev-python/tenacity/metadata.xml
new file mode 100644
index 000000000000..b607cbfe326d
--- /dev/null
+++ b/dev-python/tenacity/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Tenacity is an Apache 2.0 licensed general-purpose retrying library, written in Python, to simplify the task of adding retry behavior to just about anything. It originates from a fork of Retrying.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">tenacity</remote-id>
+ <remote-id type="github">jd/tenacity</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tenacity/tenacity-3.7.1.ebuild b/dev-python/tenacity/tenacity-3.7.1.ebuild
new file mode 100644
index 000000000000..8ed0e24a1174
--- /dev/null
+++ b/dev-python/tenacity/tenacity-3.7.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ dev-python/debtcollector[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/tenacity/tenacity-4.4.0.ebuild b/dev-python/tenacity/tenacity-4.4.0.ebuild
new file mode 100644
index 000000000000..e235720357e4
--- /dev/null
+++ b/dev-python/tenacity/tenacity-4.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+"