summaryrefslogtreecommitdiff
path: root/dev-python/tenacity/tenacity-8.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-24 00:11:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-24 00:11:52 +0100
commit67e5603b2844a6657dd0438fa26626b013e5567f (patch)
treee7319631fdf1c41ddbe888e89a717d1ba42af992 /dev-python/tenacity/tenacity-8.4.1.ebuild
parentbff543bb632933380da922cbfc07c67157d72d42 (diff)
gentoo auto-resync : 24:06:2024 - 00:11:52
Diffstat (limited to 'dev-python/tenacity/tenacity-8.4.1.ebuild')
-rw-r--r--dev-python/tenacity/tenacity-8.4.1.ebuild22
1 files changed, 18 insertions, 4 deletions
diff --git a/dev-python/tenacity/tenacity-8.4.1.ebuild b/dev-python/tenacity/tenacity-8.4.1.ebuild
index 6b916a7dff79..b5cd20a6c3cd 100644
--- a/dev-python/tenacity/tenacity-8.4.1.ebuild
+++ b/dev-python/tenacity/tenacity-8.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -16,14 +16,28 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
- >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
- dev-python/typeguard[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ ' 3.{10..12})
)
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ if ! has_version ">=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_tornado.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}