summaryrefslogtreecommitdiff
path: root/dev-python/tempora/tempora-5.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 05:38:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 05:38:21 +0100
commitd6260e76da0a436affc6839e470dd8619841cadc (patch)
treeca1df2a7c2e422ab51b16244374ae8ba94ab784e /dev-python/tempora/tempora-5.2.2.ebuild
parent6990d0600970cefe6aa2c17668f9028b08d23441 (diff)
gentoo auto-resync : 11:04:2023 - 05:38:21
Diffstat (limited to 'dev-python/tempora/tempora-5.2.2.ebuild')
-rw-r--r--dev-python/tempora/tempora-5.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/tempora/tempora-5.2.2.ebuild b/dev-python/tempora/tempora-5.2.2.ebuild
new file mode 100644
index 000000000000..dca7d962b13e
--- /dev/null
+++ b/dev-python/tempora/tempora-5.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest