summaryrefslogtreecommitdiff
path: root/dev-python/tempita/tempita-0.5.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/tempita/tempita-0.5.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/tempita/tempita-0.5.3-r1.ebuild')
-rw-r--r--dev-python/tempita/tempita-0.5.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/tempita/tempita-0.5.3-r1.ebuild b/dev-python/tempita/tempita-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..4cb6f4d0d6a2
--- /dev/null
+++ b/dev-python/tempita/tempita-0.5.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_PN="Tempita"
+MY_P="${MY_PN}-${PV}dev"
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="http://pythonpaste.org/tempita https://pypi.python.org/pypi/Tempita"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}dev"
+# Source for tests incomplete