summaryrefslogtreecommitdiff
path: root/dev-python/tempest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-27 23:32:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-27 23:32:51 +0100
commit881ed853a610750628d101d50410e9f3bf370d87 (patch)
tree1e83f90631d71c2e2b0376bb0e725f49ede671da /dev-python/tempest
parent5b4dc9f80a36fa17a541592b7bd29d31418e6a7b (diff)
gentoo auto-resync : 27:09:2023 - 23:32:51
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest2
-rw-r--r--dev-python/tempest/tempest-36.0.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 4e28287b355e..b80f2fff4ec9 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,3 +1,5 @@
DIST tempest-35.0.0.tar.gz 1144022 BLAKE2B dd333ac1271ef51171ff7d06931138a6de5872a86e2ed49c4d94b37431f6f94092069eef6700e453ab6e5fc04f004f5bd040af64ea98531bf56eba5edc9394b3 SHA512 c8986e13c821c8861f0b9c1b37c71a1017cd6de480a5efdcc646b51d1c7032a236f98735d0f77240fc9ec9eb711638a12f7a4a8d67e99c76bc1f6b561c39c61d
+DIST tempest-36.0.0.tar.gz 1137446 BLAKE2B f645b35b42252dc2bb4b7e1a3f609ee31e76d60e952c2ebb2a404b5f2e40b449aed0815631e922dffc71bd1598a5554277b851f54b99a37a1af328de171ec3ac SHA512 1d931052aa3fd9c76dc6ea23f861d43842877158307877235f5fc64d8a2a0a65dedefebec7ef5a7153aad7ccc3fc9954a882696adbaa6800af9ea2eb652790dc
EBUILD tempest-35.0.0.ebuild 2197 BLAKE2B 20d0164a60796d674ab0423312c1bebba20ece88d00871c9203b4b8ec9cb99b416b3c3c0d94c4e8d148177c3ef59576d09939806597cbfa2483b6b752d1d7666 SHA512 bb24e09d42f53569928cdae5496a885af369c68e3b1b01fe01cf201a98ee39a92a7fe343700258e9b9ccdfc72be9f588bf47872441a05feb80cd30490719f275
+EBUILD tempest-36.0.0.ebuild 2200 BLAKE2B ebea9980ad84079924e644bda703f8023e7c370d0ab05c3a21a7c8a6b5dab1ac7df0eb366570a647a129b0d6ddf4514c69f4510d48d85edb4b6af30e7c915509 SHA512 0fdbf6bc101fd47ed8f03abe0feac84cbacad60dbf2f83e71bca277219a8cb4c97161a827ea86b6f657b9e0caf057cdd09e1b3184c102ef07680340ced9d48ba
MISC metadata.xml 442 BLAKE2B 30b474d10a59f53672390e029ffaf894cfe52862af42814ca09500372d4c94afc596177100b9ba69cfd12965e98809de363527d9db345c3b4cf499eaab0375f9 SHA512 d84466ecac31486c92a6c5f87089616b65a1f3cbe9447c3382021af57bec3964a80d4d4421783560528e80e70afb4f4ba604bf2a4e23ac7fcbd873ef3d789859
diff --git a/dev-python/tempest/tempest-36.0.0.ebuild b/dev-python/tempest/tempest-36.0.0.ebuild
new file mode 100644
index 000000000000..93fcb0ff084e
--- /dev/null
+++ b/dev-python/tempest/tempest-36.0.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenStack Integration Testing"
+HOMEPAGE="
+ https://pypi.org/project/tempest/
+ https://docs.openstack.org/tempest/latest/
+ https://launchpad.net/tempest/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.16.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Small subset of tests, which fail as result of not using specific
+ # testing environment. Others expect to run suite using stestr.
+ rm -r tempest/tests/lib/services/volume/v3/ || die
+ rm tempest/tests/test_list_tests.py || die
+ rm tempest/tests/lib/cmd/test_check_uuid.py || die
+
+ # remove dep on hacking
+ rm tempest/tests/test_hacking.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv "${BUILD_DIR}"/install/{usr/,}etc || die
+}
+
+python_test() {
+ local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
+ local -x OS_TEST_TIMEOUT=300
+ eunittest -b -s tempest/tests -t .
+}