summaryrefslogtreecommitdiff
path: root/dev-python/tekore/tekore-5.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 05:24:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 05:24:22 +0000
commitfdbd219bffd44c5fa62c89f7dc329673445ee026 (patch)
tree0e37bcfa502fe395603052eee0483ff956d10ddd /dev-python/tekore/tekore-5.2.1.ebuild
parent40d8bc05c536b6c3fa0bd58c50480dc79c6b9e92 (diff)
gentoo auto-resync : 23:11:2023 - 05:24:22
Diffstat (limited to 'dev-python/tekore/tekore-5.2.1.ebuild')
-rw-r--r--dev-python/tekore/tekore-5.2.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/tekore/tekore-5.2.1.ebuild b/dev-python/tekore/tekore-5.2.1.ebuild
new file mode 100644
index 000000000000..d6db14a71ee0
--- /dev/null
+++ b/dev-python/tekore/tekore-5.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.26[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)